#opendaylight-meeting: tsc

Meeting started by colindixon at 17:01:36 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:01:43)
    1. colindixon (colindixon, 17:01:45)
    2. TSC Members please #info in (phrobb2, 17:01:57)
    3. Chris Price (ChrisPriceAB, 17:02:15)
    4. dfarrell07 for cdub and Red Hat (dfarrell07, 17:02:20)
    5. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=30131#Agenda time-static agenda in it’s usual place (colindixon, 17:02:57)
    6. LuisGomez (LuisGomez, 17:02:59)
    7. edwarnicke (edwarnicke, 17:04:04)
    8. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-04-30-17.00.html meeting minutes from last week (for action items) (colindixon, 17:04:26)
    9. jamoluhrsen changed the scripts for performance to record at least 6 months of performance data (colindixon, 17:06:12)
    10. ACTION: LuisGomez and tykeal and jamoluhrsen to work out retaining the performance metrics for as long as we can (colindixon, 17:06:56)
    11. ACTION: snoble and LuisGomez to connect and talk about trying to do some Ixia testing for Lithium (colindixon, 17:07:28)

  2. events (colindixon, 17:07:56)
    1. http://www.opendaylight.org/news/events/ ODL events page (colindixon, 17:08:11)
    2. lots of people at NFV world congress, our mini-summit there is this afternoon (colindixon, 17:08:25)
    3. ODL Mini Summit is today at NFV World Congress (dfarrell07, 17:08:26)
    4. CFP for ODL Dev Track for ONS closes tomorrow (colindixon, 17:09:08)
    5. OpenStack Summit comming up, ODL stuff going on there (dfarrell07, 17:09:11)

  3. lithium (colindixon, 17:09:34)
    1. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1196332566 the project status tracking status (colindixon, 17:10:13)
    2. gzhao says that right now most things look good, we’ll know more next week when all projects hit M5, and his guess is that 4-5 projects will drop from the release sometime around there (colindixon, 17:10:55)
    3. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 blocking bugs for lithium, same sheet, different tab (colindixon, 17:11:25)
    4. https://wiki.opendaylight.org/view/Weather#Lithium_Blocking_Bugs Blocking Bugs wiki (dfarrell07, 17:12:01)
    5. Youcef Laribi (Youcef, 17:12:28)
    6. gzhao suggests that "lead" for blocking bugs should be the project lead by default, dfarrell07 agrees (dfarrell07, 17:12:40)
    7. ACTION: zxiiro will talk to offset-1 projects about cutting their branches and bump their versions (dfarrell07, 17:14:05)
    8. ACTION: zxiiro will create JJB for offset2 projects (zxiiro, 17:14:25)

  4. migration from helium to lithium (colindixon, 17:14:28)
    1. jmedved (jmedved, 17:14:31)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-May/003014.html the thread starting things (colindixon, 17:14:36)
    3. colindixon describes various options for how to do migration (dfarrell07, 17:15:57)
    4. migration options could range from just-docs to auto-magic-script (dfarrell07, 17:16:15)
    5. tykeal asks if config files are versioned, the answer is that yes they are, but that the helium and lithium versions are teh same most of the time and we don’t have tools (colindixon, 17:23:00)
    6. it seems like there is some common work aorund upgrading the karaf container and laying down new binaries, and the projects might need to do their own special logic to handle config files and maybe data (colindixon, 17:24:01)
    7. technical discussion about upgrade approaches (dfarrell07, 17:25:58)
    8. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade (colindixon, 17:26:06)
    9. jmedved suggests that they way to do it is in a cluster where you bring down an old node, bring up a new one and then focus on ingesting the old data (colindixon, 17:26:50)
    10. tony points out that migrating the data is going to be tricky (colindixon, 17:27:16)

  5. system integration and test (colindixon, 17:28:16)
    1. LuisGomez says they’re working to get more scalability, performance, etc. tests (colindixon, 17:28:40)
    2. LuisGomez asks if we can branch all together to get better tracking (colindixon, 17:29:10)
    3. LuisGomez points out that projects should likely branch at about the same time to keep CI healthy (dfarrell07, 17:29:11)
    4. This CI issue mentioned above is a result of jobs triggering from master, so once new branch is cut a set of jobs aren't triggered (dfarrell07, 17:30:12)
    5. ACTION: colindixon to work with LuisGomez to understand the issue around triggering things across branches during releases and find fixes (colindixon, 17:31:25)
    6. Possible issue with blocking offset-0 projects by doing all cutting at the same time, rovarga points out (dfarrell07, 17:32:03)
    7. https://lists.opendaylight.org/pipermail/release/2015-April/002044.html email saying that iit’s possible test a patch before merging (colindixon, 17:34:53)
    8. the keyword is `test-integration`, to save a click (dfarrell07, 17:35:24)
    9. ACTION: LuisGomez and/or zxiiro will add that keyword to proper wiki (dfarrell07, 17:36:00)
    10. ACTION: LuisGomez to migrate those instructions to this wiki page: https://wiki.opendaylight.org/view/RelEng/Builder (colindixon, 17:36:06)
    11. https://wiki.opendaylight.org/view/RelEng/Builder/Jenkins (colindixon, 17:36:22)

  6. Infrastructure (dfarrell07, 17:36:35)
    1. Thanh is a minor god who fixes jenkins (colindixon, 17:37:12)
    2. zxiiro got a new plugin into Jenkis that should fix Zombie slave issue (dfarrell07, 17:37:20)
    3. https://lists.opendaylight.org/pipermail/tsc/2015-May/003015.html (colindixon, 17:37:39)

  7. Nemo Creation Review (phrobb2, 17:38:15)
    1. https://wiki.opendaylight.org/view/Project_Proposals:NEMO proposal (colindixon, 17:38:20)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2015-March/000299.html e-mail asking for the proposal a long time ago (colindixon, 17:38:49)
    3. Proposed on 3/21/2015 (dfarrell07, 17:39:01)
    4. ACTION: helen_chen to make sure the commiters have their ODL user ID (colindixon, 17:40:36)
    5. https://lists.opendaylight.org/pipermail/tsc/2015-May/003015.html (colindixon, 17:45:25)
    6. VOTE: Voted on "Shall the TSC approve the NEMO project to enter the incubation lifecycle state?" Results are, +1: 6 (phrobb2, 17:57:11)
    7. AGREED: NEMO has entered the incubation lifecycle state (phrobb2, 17:57:36)

  8. beryllium release planning and other things (colindixon, 17:57:57)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-May/002985.html active, very good thread on the topic (colindixon, 17:58:06)

  9. TSC meeting during the OpenStack summit (colindixon, 17:58:46)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-May/003044.html vote on whether you want to have the TSC meeting during OpenStack (colindixon, 17:59:00)
    2. ACTION: phrobb2 to see if we can find a room (colindixon, 17:59:08)

  10. cookies (colindixon, 17:59:49)
    1. http://sweetsugarbelle.com/blog/wp-content/uploads/2011/06/5682713842_c918c4904c_b.jpg <- cookies in honor of recent Cinco de Mayo (tykeal, 17:59:57)


Meeting ended at 18:00:05 UTC (full logs).

Action items

  1. LuisGomez and tykeal and jamoluhrsen to work out retaining the performance metrics for as long as we can
  2. snoble and LuisGomez to connect and talk about trying to do some Ixia testing for Lithium
  3. zxiiro will talk to offset-1 projects about cutting their branches and bump their versions
  4. zxiiro will create JJB for offset2 projects
  5. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade
  6. colindixon to work with LuisGomez to understand the issue around triggering things across branches during releases and find fixes
  7. LuisGomez and/or zxiiro will add that keyword to proper wiki
  8. LuisGomez to migrate those instructions to this wiki page: https://wiki.opendaylight.org/view/RelEng/Builder
  9. helen_chen to make sure the commiters have their ODL user ID
  10. phrobb2 to see if we can find a room


Action items, by person

  1. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade
    2. colindixon to work with LuisGomez to understand the issue around triggering things across branches during releases and find fixes
  2. LuisGomez
    1. LuisGomez and tykeal and jamoluhrsen to work out retaining the performance metrics for as long as we can
    2. snoble and LuisGomez to connect and talk about trying to do some Ixia testing for Lithium
    3. colindixon to work with LuisGomez to understand the issue around triggering things across branches during releases and find fixes
    4. LuisGomez and/or zxiiro will add that keyword to proper wiki
    5. LuisGomez to migrate those instructions to this wiki page: https://wiki.opendaylight.org/view/RelEng/Builder
  3. phrobb2
    1. phrobb2 to see if we can find a room
  4. tykeal
    1. LuisGomez and tykeal and jamoluhrsen to work out retaining the performance metrics for as long as we can
  5. zxiiro
    1. zxiiro will talk to offset-1 projects about cutting their branches and bump their versions
    2. zxiiro will create JJB for offset2 projects
    3. LuisGomez and/or zxiiro will add that keyword to proper wiki


People present (lines said)

  1. colindixon (61)
  2. dfarrell07 (52)
  3. ChrisPriceAB (13)
  4. odl_meetbot (13)
  5. tykeal (11)
  6. phrobb2 (6)
  7. zxiiro (3)
  8. edwarnicke (3)
  9. gzhao (2)
  10. LuisGomez (2)
  11. lori (2)
  12. Youcef (2)
  13. rovarga (1)
  14. jmedved (1)
  15. icbts (1)
  16. alagalah (1)
  17. odl-casey (1)
  18. phrobb (0)
  19. tbachman (0)


Generated by MeetBot 0.1.4.