#opendaylight-meeting: weekly lithium IRC sync

Meeting started by colindixon at 14:30:55 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 14:31:05)
    1. colindixon for docs, ttp and tsc (colindixon, 14:31:34)
    2. gzhao for release (gzhao, 14:32:01)
    3. edwarnicke (edwarnicke, 14:32:20)
    4. hideyuki for vtn (hideyuki_, 14:32:34)
    5. LuisGomez integration (LuisGomez, 14:33:29)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2015/weekly_lithium_irc_sync/opendaylight-meeting-weekly_lithium_irc_sync.2015-04-08-14.31.html meetings from the last sync (two weeks ago) (colindixon, 14:33:32)
    7. abhijitkumbhare OF Plugin (abhijitkumbhare, 14:35:46)
    8. shreyas for Persistence Store Service (Shreyas_, 14:36:01)
    9. https://wiki.opendaylight.org/view/Weather the weather page for tracking cross-project issues (colindixon, 14:36:23)
    10. lori for lispflowmapping (lori, 14:37:05)

  2. Karaf 3.0.3 migration (colindixon, 14:37:26)
    1. the Karaf 3.0.3 migration was harder than expected, but I *think* we’re through it (colindixon, 14:37:39)
    2. LuisGomez asks if the Karaf 3.0.3 migration is complete, edwarnicke says that he’s not aware of any issues (colindixon, 14:40:28)
    3. LuisGomez says they’re investigating an issue in the robot framework after the Karaf issues (colindixon, 14:41:22)
    4. SSH execute remote command in Karaf console does not work anymore… (LuisGomez, 14:41:45)
    5. ACTION: gzhao to add a line item to the next milestone report out for projects to report if they have experienced any issues since the upgrade to Karaf 3.0.3 (colindixon, 14:42:14)
    6. LuisGomez will provide more information about the ssh execute remote issue when they find the root cause (colindixon, 14:42:49)
    7. ACTION: gzhao could also try to gather information earlier at his discretion (colindixon, 14:43:01)

  3. projects under leadership change (colindixon, 14:43:09)
    1. gzhao would like updated project leads and primary contacts from projects which have had recent changes (colindixon, 14:45:16)
    2. gzhao says that he believes that affects DIDM, discovery, and others (colindixon, 14:45:35)
    3. ACTION: gzhao, phrobb and colindixon to identify projects which may have had changes in primary contact and/or project lead and attempt to contact them (colindixon, 14:46:31)
    4. ACTION: ANY PROJECT WITH A PTL OR PRIMARY CONTACT CHANGE please update the lithium release plan and your project facts block on your main page with the new information (colindixon, 14:47:08)
    5. ACTION: regXboi or edwarnicke to post something about moxy and the interaction between restconf and neutron northbound to the weather page (colindixon, 14:48:04)
    6. ACTION: colindixon and/or phrobb to see if they can wrangle somebody to help with moxy issues (colindixon, 14:48:25)

  4. Karaf 3.0.4 (colindixon, 14:48:45)
    1. hideyuki_ asks if we will move to 3.0.4 during Lithium (colindixon, 14:48:55)
    2. colindixon says he thinks not for Lithium given our stage in the cycle (colindixon, 14:49:08)

  5. per-project documentation and integration readouts (colindixon, 14:52:08)
    1. ACTION: LuisGomez to provide a list of project statuses for system test in Lithium (colindixon, 14:52:55)
    2. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit?pli=1#gid=613128231 documentation status is listed here, note *many* projects are red :-( (colindixon, 14:53:51)

  6. Java 8 (colindixon, 14:53:55)
    1. lori and rovarga ask about moving to being Java 8 compatible in Lithium (colindixon, 14:54:13)
    2. lori notes that moving to Karaf 3.0.3 was part of that effort, but removing enunciate was another part (colindixon, 14:54:49)
    3. VTN project is working on migrating Helium documents into Lithium documents. (hideyuki_, 14:54:50)
    4. lori notes that lispflowmapping is one of the projects using enunciate and while they will deprecate their usage in Lihtium, they can’t remove it in Lithium (colindixon, 14:55:36)
    5. in that case, it may be that we target Java 8 compatibility in Beryllium (colindixon, 14:59:01)
    6. ACTION: colindixon and gzhao to reach out to rovarga, lori and others to figure out if we can get Java 8 in Lithium and plan for how to get there otherwise (colindixon, 14:59:42)

  7. cookies (colindixon, 14:59:45)


Meeting ended at 14:59:51 UTC (full logs).

Action items

  1. gzhao to add a line item to the next milestone report out for projects to report if they have experienced any issues since the upgrade to Karaf 3.0.3
  2. gzhao could also try to gather information earlier at his discretion
  3. gzhao, phrobb and colindixon to identify projects which may have had changes in primary contact and/or project lead and attempt to contact them
  4. ANY PROJECT WITH A PTL OR PRIMARY CONTACT CHANGE please update the lithium release plan and your project facts block on your main page with the new information
  5. regXboi or edwarnicke to post something about moxy and the interaction between restconf and neutron northbound to the weather page
  6. colindixon and/or phrobb to see if they can wrangle somebody to help with moxy issues
  7. LuisGomez to provide a list of project statuses for system test in Lithium
  8. colindixon and gzhao to reach out to rovarga, lori and others to figure out if we can get Java 8 in Lithium and plan for how to get there otherwise


Action items, by person

  1. colindixon
    1. gzhao, phrobb and colindixon to identify projects which may have had changes in primary contact and/or project lead and attempt to contact them
    2. colindixon and/or phrobb to see if they can wrangle somebody to help with moxy issues
    3. colindixon and gzhao to reach out to rovarga, lori and others to figure out if we can get Java 8 in Lithium and plan for how to get there otherwise
  2. edwarnicke
    1. regXboi or edwarnicke to post something about moxy and the interaction between restconf and neutron northbound to the weather page
  3. gzhao
    1. gzhao to add a line item to the next milestone report out for projects to report if they have experienced any issues since the upgrade to Karaf 3.0.3
    2. gzhao could also try to gather information earlier at his discretion
    3. gzhao, phrobb and colindixon to identify projects which may have had changes in primary contact and/or project lead and attempt to contact them
    4. colindixon and gzhao to reach out to rovarga, lori and others to figure out if we can get Java 8 in Lithium and plan for how to get there otherwise
  4. lori
    1. colindixon and gzhao to reach out to rovarga, lori and others to figure out if we can get Java 8 in Lithium and plan for how to get there otherwise
  5. LuisGomez
    1. LuisGomez to provide a list of project statuses for system test in Lithium
  6. phrobb
    1. gzhao, phrobb and colindixon to identify projects which may have had changes in primary contact and/or project lead and attempt to contact them
    2. colindixon and/or phrobb to see if they can wrangle somebody to help with moxy issues
  7. rovarga
    1. colindixon and gzhao to reach out to rovarga, lori and others to figure out if we can get Java 8 in Lithium and plan for how to get there otherwise


People present (lines said)

  1. colindixon (65)
  2. gzhao (12)
  3. LuisGomez (11)
  4. odl_meetbot (7)
  5. lori (4)
  6. hideyuki_ (4)
  7. edwarnicke (3)
  8. abhijitkumbhare (3)
  9. rovarga (1)
  10. Shreyas_ (1)
  11. phrobb (0)
  12. dfarrell07 (0)


Generated by MeetBot 0.1.4.