#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai at 16:57:52 UTC (full logs).

Meeting summary

  1. Agenda (Sai, 16:59:46)
    1. 1. Call for any topics to be added to the agenda that people didn't get around to adding. (Sai, 17:00:17)
    2. 2.Review the existing action items (PDF provided by email). (Sai, 17:00:45)
    3. 3.Introduce the Boron Planning Page. (Sai, 17:00:53)
    4. 4.Bug 5345 - Unable to use get-schema RPC due to unsafe class casting [1] Status change from "In Progress" to "Confirmed". What is the plan for this? (Sai, 17:01:02)
    5. 5.Bug 4688 - QNameModule.getRevision() should return a specialized object [2] (Sai, 17:01:11)
    6. 6.odlparent "Upgrade Bouncycastle 1.52 -> 1.53"; why not 1.54? CVE-2015-7575 was fixed in 1.54 [3] (Sai, 17:01:20)
    7. 7.odlparent "Upgrade jolokia 1.3.1 -> 1.3.2" why not 1.3.3? [4] required for AAA in Boron (Sai, 17:01:31)
    8. 8. Odlparent "bundle-parent should pull in junit" [5] Should all bundles inherit from bundle-parent instead of odlparent? (Sai, 17:01:50)

  2. Last-Meeting-Notes-Items-link (Sai, 17:02:22)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-02-16-17.00.html (Sai, 17:02:28)
    2. - Bug2912 solved by colin (Sai, 17:04:57)
    3. - Ryan / TomP opened bug 5289 wrt followup of Bug4866 (Sai, 17:06:10)
    4. - Ryan opened enhancement bug5407 wrt deprecating netconf (Sai, 17:07:09)
    5. - Tony sent an email regarding boron release plan for controller (Sai, 17:07:52)
    6. - colindixon suggests sharding & upgradability are the two topics which should be part of every project (Sai, 17:08:34)

  3. - Boron planning (Sai, 17:11:11)
    1. - New page view/boron_planning is created (Sai, 17:11:23)

  4. - Bug5345 (Sai, 17:11:32)
    1. - TOny & team would work on the bug (Sai, 17:11:50)

  5. - bug 4688 (Sai, 17:12:03)
    1. - Robert says it should NOT affect any other project. (Sai, 17:14:12)
    2. - Thanks abhijitkumbhare for correction (Sai, 17:14:23)

  6. - Upgrade bouncycastle (Sai, 17:14:37)
    1. - Stephen opened a new bug to upgrade to 1.54 (Sai, 17:15:19)

  7. bundle-parent (Sai, 17:15:51)
    1. - Should all bundles inherit from bundle-parent instead of odlparent? (Sai, 17:16:24)
    2. - Robert says it depends (Sai, 17:16:47)
    3. - Robert says patch 35124 address this issue (Sai, 17:17:20)
    4. - Ryan says he will look further in to it (Sai, 17:17:59)
    5. ACTION: - Ryan looks through patch 35125 and will send points. (Sai, 17:19:18)

  8. - Boron Planning (Sai, 17:20:06)
    1. - https://wiki.opendaylight.org/view/Boron_Planning (Sai, 17:21:17)
    2. - Topic Upgrade Compatibility (Sai, 17:21:59)
    3. - Advisory thinks this is the single most flaw in ODL (Sai, 17:22:25)
    4. - colin says we need to device a plan through we can have atleast some projects supporting upgradability (Sai, 17:23:37)
    5. - Losing data while upgrading (Sai, 17:24:20)
    6. - MD-Sal data store & config sub system are the two data (Sai, 17:24:56)
    7. - Losing data refers to MD-SAL, if schema changes users wont be able to migrate. (Sai, 17:25:37)
    8. - When yang data schema model changes users won't be able to follow persistence (Sai, 17:26:26)
    9. - TomP Says when code wiring changes / user configuration changes it becomes problem wrt upgradability (Sai, 17:27:26)
    10. - TomP says Third topic Karaf upgradability is the third topic (Sai, 17:29:12)
    11. - These corresponds to in place upgrade (stop/start) vs service upgrade (where controller keeps running) (Sai, 17:30:23)
    12. - Rolling upgrades are difficult since all the nodes may not contain same schema/version (Sai, 17:35:04)
    13. - TomP says theoretically there are no infrastructure limitations wrt clustering (Sai, 17:36:20)
    14. - Ashutosh agrees with TomP that we should not make insfrastructure as bottleneck. (Sai, 17:38:17)
    15. - infrastructure & application level testing are both equally necessary (Sai, 17:40:09)
    16. - Ashutosh says scoping the guidelines on how to do backward compatibility should be included (Sai, 17:42:43)
    17. - Ashutosh says scripts helps in translating data from previous to current. Is it possible to not use scripts and have a better plan ? (Sai, 17:44:53)
    18. - TomP is in favor of moving away from config subsystem. Prefers blue print. (Sai, 17:46:33)
    19. - Robert asks if blueprint is for boron ? boron uses only blueprint ? (Sai, 17:50:16)
    20. - TomP says boron could be both (blueprint / config subsystem) (Sai, 17:50:55)
    21. - TomP thinks both cannot co-exist together (Sai, 17:54:14)
    22. - An Ho requests that we should make sure that there should not be any incompatible issues for end users (Sai, 17:59:40)
    23. - Sai/Ryan/Abhijith/Ashutosh/An Ho/ Gary/ Martin / Robert / Stephen / TomP / Tony (Sai, 18:07:31)


Meeting ended at 18:07:47 UTC (full logs).

Action items

  1. - Ryan looks through patch 35125 and will send points.


People present (lines said)

  1. Sai (62)
  2. odl_meetbot (4)
  3. abhijitkumbhare (1)


Generated by MeetBot 0.1.4.