#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai at 17:00:08 UTC (full logs).

Meeting summary

  1. lastmeeting minutes (Sai, 17:01:05)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-02-23-16.57.html (Sai, 17:01:11)

  2. Agenda Bashing (Sai, 17:01:19)
    1. - 1. followup Action items (Sai, 17:02:54)
    2. 2. Enhanced Wiki Format for Past Notes (Sai, 17:02:58)
    3. - 3.Boron M1 Offset 0 Status Due 3/10 [2] (Sai, 17:03:07)
    4. - 4.Bug 5345 Unable to use get-schema RPC due to unsafe class casting [3] (Sai, 17:03:21)
    5. - 5.DCL -> DTCL conversion example patch done by Tom Pantelis [4] (Sai, 17:03:31)
    6. - 6.Bump akka from 2.3.14 -> 2.4.1 Merged (Sai, 17:03:48)
    7. - 7.Bug 2825 Deficiencies in current yangtool generation of ietf types [5] (Sai, 17:04:03)

  3. - Review the existing action items (Sai, 17:05:56)
    1. - Ryan looking through it and send out an email this week (Sai, 17:06:22)
    2. ACTION: - Ryan to followup on patch 35124 (Sai, 17:06:58)

  4. - Enhanced Wiki Format for Past Notes (Sai, 17:07:28)
    1. - new look with all meeting notes & age4nda are updated here (Sai, 17:07:43)

  5. - Boron M1 Offset 0 Status Due 3/10 [2] (Sai, 17:07:50)
    1. - Ryan says PTL has to take care of the plan (Sai, 17:08:13)
    2. - Projects likely to be ready for the offset 0 status (Sai, 17:08:49)
    3. ACTION: - Ryan sends an email informaingall the projects about Boron M1 Offset status (Sai, 17:09:13)

  6. - Bug 5345 (Sai, 17:09:25)
    1. - Martin suggests custom mini schema context is the mini solution (Sai, 17:10:46)
    2. - Martin is busy with beryllium, and expects the bug can wait till SR1 (Sai, 17:11:09)

  7. - DCL to DTCL (Sai, 17:13:03)
    1. - DCL to be deprecated in boron timeframe (Sai, 17:13:36)
    2. - TomP submitted a patch modifying the toaster example which is useful for DTCL (Sai, 17:14:05)
    3. - Toaster example doesn't have children (Sai, 17:14:53)
    4. ACTION: - Ryan tried to make a better example of toaster or similar which has changes in children (DTCL replication) (Sai, 17:15:32)
    5. ACTION: - Ryan will make a better example of toaster or similar which has changes in children (DTCL replication) (Sai, 17:15:54)
    6. - Ericsson when trying to replicate with million flows observed performance problems with DCL, with DTCL we expect to increase the performance (Sai, 17:17:46)
    7. - it includes API changes (Sai, 17:19:28)
    8. - Abhijit suggests it may be a good candidate for deprecation , better leave the decision to project folks (project will select between DCL , DTCL based on performance ) (Sai, 17:21:12)
    9. ACTION: - Ryan works with TomP on recommendation of DTCL over DCL especially wrt to performance point of view (Sai, 17:22:01)

  8. - Akka from 2.3.14 -> 2.4.1 (Sai, 17:22:24)
    1. - version is bumped (Sai, 17:22:58)

  9. - Bug 2825 (Sai, 17:23:08)
    1. - several patches merged, to be followed up in next meeting (Sai, 17:23:33)

  10. - Upgrades (Sai, 17:23:40)
    1. - TomP asks Abhijit about the path forward regarding upgrades (Sai, 17:24:44)
    2. - TomP says it includes community wide effort to make upgrades possible (Sai, 17:25:47)
    3. - TomP comes up with Blueprint which is going to take care of hierarchy issues. (Sai, 17:26:15)
    4. - TomP says Robert agrees too. (Sai, 17:26:40)
    5. - TomP says blueprint may be longer term solution but for Boron we may need another effort or a feasible solution (Sai, 17:29:24)
    6. - Abhijit supports the idea (Sai, 17:29:53)
    7. - Ryan says during transition there will be a big responsibility on application developers (Sai, 17:35:19)
    8. - Abhijit says OpenflowPlugin has no specific plan for upgrades, but they are busy in migrating to Li framework. (Sai, 17:36:46)
    9. - TomP has a wiki page which describes the upgrade issues. (Sai, 17:38:58)
    10. - AnHo asks do we have go to push the blueprint in boron ? (Sai, 17:39:19)
    11. - Abhijit/TomP says this is just about reaching out to contributors and make sure they are aware. (Sai, 17:40:17)
    12. - TomP is interested in getting the thoughts of more people (Sai, 17:40:55)
    13. - link for config/upgrades (Sai, 17:41:28)
    14. - https://wiki.opendaylight.org/view/Upgrades_And_Config_System (Sai, 17:41:30)
    15. - AnHo says he can ask for how the projects are testing upgradability, requests TomP for step by step process on upgrade and testing. (Sai, 17:43:34)
    16. - AnHo agrees that upgrade & upgrade testing is of utmost importance, but looking for solution where projects can deal with upgrades all alone. Looking for guidelines / rules. (Sai, 17:45:39)
    17. - AnHo asks if blueprint may be a better solution for carbon ? (Sai, 17:46:34)
    18. - TomP says we can push blueprint enabled controller core initially and we can take it from there. (Sai, 17:48:04)
    19. - AnHo says TWS session may be better place on the upgrades discussion. (Sai, 17:49:21)
    20. ACTION: - TomP to send out a mail wrt upgrades including the link for uprades and config system (Sai, 17:50:12)
    21. - Ryan brings idea of compatibility (Sai, 17:52:05)
    22. - AnHo says it is a good idea for end users will benefit from compatibility matrix (Sai, 17:52:43)
    23. ACTION: - Ryan followsup with Colin on how to deal with the compatibility matrix for upgrades. (Sai, 17:53:38)
    24. - AnHo suggests TomP to go release review and add it as a contraint in the excel (Sai, 17:55:50)
    25. - https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=45904332 (Sai, 17:55:58)
    26. ACTION: - TomP to link the release review plan with upgrades & config subsystem. (Sai, 17:57:34)

  11. - Attendance (Sai, 18:04:15)
    1. - Sai/Ryan/Abhijit/Alexis/AnHo/TomP/Martin (Sai, 18:04:41)


Meeting ended at 18:05:01 UTC (full logs).

Action items

  1. - Ryan to followup on patch 35124
  2. - Ryan sends an email informaingall the projects about Boron M1 Offset status
  3. - Ryan tried to make a better example of toaster or similar which has changes in children (DTCL replication)
  4. - Ryan will make a better example of toaster or similar which has changes in children (DTCL replication)
  5. - Ryan works with TomP on recommendation of DTCL over DCL especially wrt to performance point of view
  6. - TomP to send out a mail wrt upgrades including the link for uprades and config system
  7. - Ryan followsup with Colin on how to deal with the compatibility matrix for upgrades.
  8. - TomP to link the release review plan with upgrades & config subsystem.


People present (lines said)

  1. Sai (70)
  2. odl_meetbot (4)
  3. abhijitkumbhare (2)


Generated by MeetBot 0.1.4.