#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai at 15:59:33 UTC (full logs).

Meeting summary

  1. - last-meeting-minutes (Sai, 16:00:19)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-05-10-16.01.html (Sai, 16:00:28)
    2. - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-05-10-16.01.html (Sai, 16:00:35)

  2. Agenda (Sai, 16:01:33)
    1. 1. Call for any topics to be added to the agenda (Sai, 16:01:46)
    2. 2. Review the existing action items (Sai, 16:02:16)
    3. 3. Upgrade Karaf 3.0.3 -> 3.0.6 (Sai, 16:02:48)
    4. 4. Bug 5446: Yangtools UnionStringCodec is not consistent with BinaryStringCodec (Sai, 16:03:00)
    5. 5. Bug 5788: enum used as a key does not work (Sai, 16:03:08)
    6. 6. Upgrade commons-net 3.4 -> 3.5 (Sai, 16:03:17)
    7. 7. Upgrade resteasy jaxrs-api 3.0.4 -> 3.0.12 (Sai, 16:03:26)
    8. 8. Bug 4760: YANG leaf named 'class' breaks write with netconf connector (Sai, 16:03:34)
    9. 9. Bug 5899 (Sai, 16:03:42)

  3. - Call for any topics to be added to the agenda (Sai, 16:04:12)
    1. - No added topics (Sai, 16:04:39)

  4. - Review the existing action items (Sai, 16:04:51)
    1. ACTION: - Tony to send reports regarding controller M2 status - [Tony has templates, he will send today] - [In progress] (Sai, 16:05:40)
    2. - Ryan to followup with release team wrt change regarding wrt non-equal objects return and corresponding patch. An extremely helpful - Done - https://git.opendaylight.org/gerrit/#/c/38845/ (Sai, 16:06:09)
    3. - TomP will create a bug on how to place / where to use config admin wrt Blueprint / CDS configuration strategies going forward - In progress - TomP has a patch - Please will link through the patch / bug - TomP says not need for further bug since since it is merged. - [DONE] (Sai, 16:07:55)
    4. - Ryan will take/followup the task Robert to document (release notes ? ) wrt to bug 5830. - [DONE] - Patch - https://git.opendaylight.org/gerrit/#/c/38845/ (Sai, 16:08:22)
    5. - Ryan to add documentation / release notes which suggests people should use karaf parent for downstream applications etc.- [DONE] - patch - https://git.opendaylight.org/gerrit/#/c/38845/ (Sai, 16:09:03)
    6. ACTION: - Ryan to reach intergation team (or concerned team) regarding Ubuntu 16.04 LTS package manager "default-jdk" installs 1.8.0_03-Ubuntu - [IN PROGRESS]- email thread started (Sai, 16:09:31)
    7. - TomP says there is no plan to deprecate the configsystem wrt BluePrint in this release. Tony/TomP agrees it would be a bigger deprecation than AD-SAL to MD-SAL move. (Sai, 16:14:47)
    8. - Tony/An requests for a weather page wrt BluePrint release / deprecation process. (Sai, 16:15:48)
    9. ACTION: - TomP/Tony/An/Alexis will meet to discuss on BluePrint deprecation / release / dependencies on projects. (Sai, 16:17:28)
    10. ACTION: - Alexis will add more information on Project Layout Guidelines so that users can decide which one to prefer (local or odlparent) - [In PROGRESS] - didn't get time to work on it (Sai, 16:19:07)
    11. - Robert to create a weather item about deprecating the existing RESTCONF interfaces for the new implementation (draft-11) - [DONE] - only integration & test should be affected. (Sai, 16:19:56)
    12. ACTION: - An followsup with Robert by e-mail wrt deprecating the existing RESTCONF interfaces for the new implementation (draft-11). [ compatibility issues / end user issues ] (Sai, 16:20:54)
    13. ACTION: - colindixon to followup with concerned team on how to react / document the dynamic changes of ubuntu / java wrt opendaylight - IN PROGRESS - checked with Daniel and in progress. (Possible to rely on OPNFV) (Sai, 16:21:04)

  5. - Upgrade Karaf 3.0.3 -> 3.0.6 (Sai, 16:21:23)
    1. - ongoing work (Sai, 16:21:30)

  6. - Bug 5446: Yangtools UnionStringCodec is not consistent with BinaryStringCodec (Sai, 16:21:39)
    1. - patch - https://git.opendaylight.org/gerrit/#/c/38853/ (Sai, 16:21:50)
    2. - corresponding MD-SAL change: https://git.opendaylight.org/gerrit/#/c/38272/ (Sai, 16:22:08)

  7. - Bug 5788: enum used as a key does not work (Sai, 16:22:21)
    1. - https://git.opendaylight.org/gerrit/#/c/38865/ - bug fix done (Sai, 16:22:33)

  8. - Upgrade commons-net 3.4 -> 3.5 (Sai, 16:22:44)
    1. - https://git.opendaylight.org/gerrit/#/c/32362/ (Sai, 16:22:56)

  9. - Upgrade resteasy jaxrs-api 3.0.4 -> 3.0.12 (Sai, 16:23:06)
    1. - https://git.opendaylight.org/gerrit/#/c/32362/ (Sai, 16:23:13)
    2. - raise any concerns on e-mail (Sai, 16:24:03)

  10. - Bug 4760: YANG leaf named 'class' breaks write with netconf connector (Sai, 16:24:11)
    1. - https://git.opendaylight.org/gerrit/#/c/36134/ (Sai, 16:24:37)

  11. - Bug 5899 (Sai, 16:25:30)
    1. - https://bugs.opendaylight.org/show_bug.cgi?id=5899 (Sai, 16:25:39)
    2. - Cardinality check incorrectly limited to 1 for "must" substatements in "refine" statement (Sai, 16:26:07)
    3. - Robert has to take a look at it. (Sai, 16:26:53)
    4. - Robert / Tony agrees on the idea that cardinality should be [ 0-n ] (Sai, 16:28:49)

  12. - merged patch of checkstyle in AAA (Sai, 16:29:45)
    1. - Robert requests Ryan to have a look at the patch. (Sai, 16:30:09)

  13. - system test Waiver on release 3 (Sai, 16:30:39)
    1. - An requests for system test waiver and ask if there are any objections (Sai, 16:30:55)
    2. - Robert / Tony has no objections (Sai, 16:31:17)

  14. - participants (Sai, 16:31:50)
    1. - Sai / Ryan / Alexis / An Ho / Martin / Robert / Shuva / Stephen / TomP / Tomas / Tony / Vaclav (Sai, 16:33:05)


Meeting ended at 16:33:39 UTC (full logs).

Action items

  1. - Tony to send reports regarding controller M2 status - [Tony has templates, he will send today] - [In progress]
  2. - Ryan to reach intergation team (or concerned team) regarding Ubuntu 16.04 LTS package manager "default-jdk" installs 1.8.0_03-Ubuntu - [IN PROGRESS]- email thread started
  3. - TomP/Tony/An/Alexis will meet to discuss on BluePrint deprecation / release / dependencies on projects.
  4. - Alexis will add more information on Project Layout Guidelines so that users can decide which one to prefer (local or odlparent) - [In PROGRESS] - didn't get time to work on it
  5. - An followsup with Robert by e-mail wrt deprecating the existing RESTCONF interfaces for the new implementation (draft-11). [ compatibility issues / end user issues ]
  6. - colindixon to followup with concerned team on how to react / document the dynamic changes of ubuntu / java wrt opendaylight - IN PROGRESS - checked with Daniel and in progress. (Possible to rely on OPNFV)


People present (lines said)

  1. Sai (61)
  2. odl_meetbot (5)
  3. anipbu (1)


Generated by MeetBot 0.1.4.