#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:08 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 18:00:13)
    1. colindixon (colindixon, 18:00:26)
    2. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=40151#Agenda today's agenda (colindixon, 18:00:59)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-01-07-18.00.html last week's meeting minutes for action items (colindixon, 18:01:16)
    4. Daniel Farrell (dfarrell07, 18:02:46)
    5. Eric Multanen (snackewm, 18:02:54)
    6. mohnish anumala (mohnish_, 18:02:58)
    7. jmedved (jmedved, 18:03:29)
    8. LuisGomez (LuisGomez, 18:03:47)
    9. edwarnicke (edwarnicke, 18:03:47)
    10. ACTION: colindixon to keep boron planning on our minds (colindixon, 18:04:08)
    11. https://lists.opendaylight.org/pipermail/tsc/2016-January/004552.html Cross-project breakage thread (dfarrell07, 18:04:24)
    12. ACTION: jamoluhrsen to go update the wikis with relevant "now approved" pointers/info (colindixon, 18:06:57)
    13. https://lists.opendaylight.org/pipermail/tsc/2016-January/004554.html best practices for preventing/handling cross-project breakages (dfarrell07, 18:07:06)
    14. ACTION: colindixon to add the best practices for preventing/handling cross-project breakages to the next TWS meeting as at least a brief topic (dfarrell07, 18:07:12)
    15. ACTION: phrobb to make sure ONS is listed under ODL's events page (colindixon, 18:07:24)
    16. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron? (colindixon, 18:07:39)
    17. ONS CFP closes 1/15 tomorrow, but keep in mind that UTC can be tricky so maybe shoot for today (dfarrell07, 18:08:13)
    18. ACTION: phrobb and/or gzhao to work with ChrisPriceAB to continue to figure out when/where/who would run a Europe boot camp (colindixon, 18:08:53)

  2. TSC elections (colindixon, 18:09:55)
    1. dfarrell07 says he was hoping to get a broader communit discussion during the last week, but it didn't happen (colindixon, 18:10:22)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-January/004545.html the end of that thread with some ideas of how to enage more people (colindixon, 18:10:49)
    3. abhijitkumbhare for ChrisPriceAB (abhijitkumbhare, 18:12:18)
    4. ACTION: colindixon and dfarrell07 to make sure there is some time (likely TWS) to try to provide more understandability (colindixon, 18:13:19)
    5. suggestion for easier feedback - more examples (dfarrell07, 18:13:59)
    6. colindixon notes some people have privately communicated to him that they felt like they felt like they would be more likely to embarass themselves than provide valuable feedback, which probably needs some explicit attention (colindixon, 18:14:32)
    7. dfarrell07 has been working on an ODL election machine in python, but it might help to geneate examples (colindixon, 18:15:29)
    8. abhijitkumbhare says if we need tooling, things might be more complicated than is a good idea (colindixon, 18:16:38)
    9. VOTE: Voted on "will you be here for the TWS on Monday if we have it on MLK day?" Results are, yes: 3, no: 6 (colindixon, 18:20:01)
    10. it sounds like it's not worth doing, actually 7 nos and only 3 yeses (colindixon, 18:20:16)

  3. events (colindixon, 18:20:40)
    1. ACTION: colindixon phrobb_ to get TWS topics squared away (dfarrell07, 18:20:44)
    2. https://www.opendaylight.org/global-events (colindixon, 18:20:51)
    3. the CFP for ONS is closing TOMORROW (colindixon, 18:21:01)
    4. OpenStack's CFP is open until the end of the month (colindixon, 18:21:12)
    5. phrobb_ is at a modeling workshop that the ETSi people put toegether with ~12 SDOs and a handfull of open source projects (colindixon, 18:22:04)
    6. phrobb_ says that there is only one ONS application place, not a separate track for ODL (colindixon, 18:22:52)

  4. pre-boron (colindixon, 18:23:06)
    1. branch cutting and version bumping will be done today after the meeting (colindixon, 18:23:27)
    2. this will involve removing all the pre-boron jobs and then creating boron jobs to cover master after branch cutting (colindixon, 18:24:00)
    3. autorelease-validate jobs will have to be disabled during branch cutting (colindixon, 18:24:14)
    4. zxiiro says he's planning to keep the pre-boron branch around for a month to make sure he cherry-picks everything correctly, then he'll likely delete the branches (colindixon, 18:25:00)
    5. zxiiro says his current plan is to just cherry-pick, but not merge patches (colindixon, 18:25:53)

  5. Beryllium (colindixon, 18:27:33)
    1. offset 2 M5 is due today (colindixon, 18:27:39)
    2. anipbu notes that we had an issue with LACP breaking autorelease, it's been reverted and fixed so things are again moving (colindixon, 18:28:12)
    3. the build for RC0 will start on 1/21 (about a week from now) (colindixon, 18:28:28)
    4. https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the weather (colindixon, 18:28:44)
    5. there is a meeting at 9a on Monday to attend a meeting to figure out about conflicting OpenFlow plugin designs conflict (-li vs. normal) (colindixon, 18:29:18)
    6. anipbu says we need to address it in Beryllium in some way (colindixon, 18:29:59)
    7. rovarga asks if this will be a possible Beyllium slippage, anipbu and colindixon say the really hope and believe not (colindixon, 18:31:31)
    8. rovarga says he thinks this does pose some risks to the release (colindixon, 18:32:51)
    9. colindixon, abhijitkumbhare, LuisGomez, and others say the worst case is to carefully document things, we can still hope for a better way (colindixon, 18:34:04)
    10. colindixon says the bare minimum of what he'd want to see us do is provide a validator that will let you know if you've managed to install conflicting things (colindixon, 18:37:07)
    11. the monday meeting about this is just the normal OF plugin meeting, so find details on their homepage (colindixon, 18:37:51)
    12. every wednesday at 7:30a pacific time we have a Beyrllium sync on IRC in #opendaylight-meeting (this room), please attend (colindixon, 18:38:28)
    13. https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/Weekly_Sync_Meeting (anipbu, 18:38:30)

  6. system integration and test (colindixon, 18:38:51)
    1. last week we checked about REST responses changing, but that's been reverted so ignore that (colindixon, 18:39:12)
    2. earlier this week, had issues with verify jobs, but they're working now (colindixon, 18:39:42)

  7. infrastructure (colindixon, 18:39:48)
    1. yesterday jenkins was basically dead (colindixon, 18:39:57)
    2. zxiiro and tykeal made jenkins and gerrit bigger and brought them back up as an emergency, and things seem happy since then (colindixon, 18:40:22)
    3. rovarga says both seem happy as a clam now (colindixon, 18:40:39)
    4. went from 30 GB of RAM to 60 GB to do this, still have 24 GB free for now (colindixon, 18:41:01)
    5. tykeal says we are at a point where we have one more larger system and after that we're out-of-luck (colindixon, 18:41:17)
    6. tykeal says we desperately need zuul and nodepool to be able to scale (colindixon, 18:41:47)
    7. dfarrell07 says that the integration call this morning also remembered the idea about maybe moving to JIRA, just to remind people that this exists (colindixon, 18:43:38)
    8. rovarga also chimes in around JIRA, colindixon suggests maling list threads, meetings and eventually documentation on how to move (colindixon, 18:45:52)

  8. OVSDB Graduation review (colindixon, 18:45:57)
    1. https://wiki.opendaylight.org/view/OVSDB_Integration:OVSDB_NetVirt_Mature_Graduation_Proposal the proposal (colindixon, 18:46:07)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2015-December/000383.html requested a review with e-mail 12/15 (colindixon, 18:46:46)
    3. ovsdb has been around since Hydrogen has meet all the milestones (colindixon, 18:47:58)
    4. it's been a pretty active project since the beginning, there is a very active community in part because of the interest in openstack netvirt (colindixon, 18:48:24)
    5. developers and users from diverse community across companies (colindixon, 18:49:25)
    6. tutorials can be found on the graudation review including links to youtube and slides showing how to get it up and working (colindixon, 18:50:22)
    7. LuisGomez says he thinks it should pass, edwarnicke says the document looks very thorough, dfarrell07 says similar things (colindixon, 18:51:04)
    8. dfarrell07 brings up the issue of the plans to split the project in two in Boron (colindixon, 18:51:32)
    9. edwarnicke notes that both sides of the project have "walked the walk" in terms of maturity and thus it would split into two mature projects (colindixon, 18:53:08)
    10. colindixon agrees and notes that this has come up repeatedly and we've always said history should count across splits if it's really the same code (colindixon, 18:53:55)
    11. VOTE: Voted on "shall the TSC graduate the OVSDB project to being a mature project?" Results are, +1: 8 (colindixon, 18:54:47)
    12. AGREED: the OVSDB project is now the second mature project in OpenDaylight (colindixon, 18:54:58)
    13. ACTION: shague to update the proposal page and your project facts page appropriately (colindixon, 18:55:17)

  9. major topics (colindixon, 18:56:14)
    1. we have three major topics of discussion (colindixon, 18:56:36)
    2. 1. Boron planning which was covered on this week's TWS at least partially (colindixon, 18:56:46)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2016/tws/opendaylight-meeting-tws.2016-01-11-18.27.html something is here (colindixon, 18:57:08)
    4. 2. TSC elections, see above (colindixon, 18:57:20)
    5. 3. openflow plugin designs and how they'll play together in Beryllium, again see above (colindixon, 18:57:43)

  10. cookies (colindixon, 18:57:57)


Meeting ended at 18:58:01 UTC (full logs).

Action items

  1. colindixon to keep boron planning on our minds
  2. jamoluhrsen to go update the wikis with relevant "now approved" pointers/info
  3. colindixon to add the best practices for preventing/handling cross-project breakages to the next TWS meeting as at least a brief topic
  4. phrobb to make sure ONS is listed under ODL's events page
  5. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
  6. phrobb and/or gzhao to work with ChrisPriceAB to continue to figure out when/where/who would run a Europe boot camp
  7. colindixon and dfarrell07 to make sure there is some time (likely TWS) to try to provide more understandability
  8. colindixon phrobb_ to get TWS topics squared away
  9. shague to update the proposal page and your project facts page appropriately


Action items, by person

  1. colindixon
    1. colindixon to keep boron planning on our minds
    2. colindixon to add the best practices for preventing/handling cross-project breakages to the next TWS meeting as at least a brief topic
    3. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
    4. colindixon and dfarrell07 to make sure there is some time (likely TWS) to try to provide more understandability
    5. colindixon phrobb_ to get TWS topics squared away
  2. dfarrell07
    1. colindixon and dfarrell07 to make sure there is some time (likely TWS) to try to provide more understandability
  3. gzhao
    1. phrobb and/or gzhao to work with ChrisPriceAB to continue to figure out when/where/who would run a Europe boot camp
  4. jamoluhrsen
    1. jamoluhrsen to go update the wikis with relevant "now approved" pointers/info
  5. phrobb
    1. phrobb to make sure ONS is listed under ODL's events page
    2. phrobb and/or gzhao to work with ChrisPriceAB to continue to figure out when/where/who would run a Europe boot camp
  6. phrobb_
    1. colindixon phrobb_ to get TWS topics squared away
  7. shague
    1. shague to update the proposal page and your project facts page appropriately


People present (lines said)

  1. colindixon (93)
  2. dfarrell07 (19)
  3. odl_meetbot (19)
  4. abhijitkumbhare (5)
  5. LuisGomez (4)
  6. edwarnicke (4)
  7. mohnish_ (4)
  8. phrobb_ (4)
  9. jmedved (3)
  10. flaviof (3)
  11. snackewm (3)
  12. ebrjohn (2)
  13. tykeal (2)
  14. alagalah (2)
  15. jamoluhrsen (2)
  16. anipbu (2)
  17. shague (2)
  18. gzhao (1)
  19. phrobb (0)


Generated by MeetBot 0.1.4.