#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:18 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:23)
    1. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=46538#Agenda the agenda for today (colindixon, 17:00:50)
    2. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-05-19-17.00.html last week's meeting minutes (colindixon, 17:01:00)
    3. Chris Price (ChrisPriceAB, 17:01:25)
    4. edwarnicke (edwarnicke, 17:01:27)
    5. colindixon (colindixon, 17:01:27)
    6. mohnish anumala (mohnish__, 17:01:35)
    7. rovarga__ for ttkacik (rovarga__, 17:01:44)
    8. abhijitkumbhare (abhijitkumbhare, 17:01:53)
    9. ACTION: phrobb and dfarrell07 to drive forward tooling and planning for the next TSC election (colindixon, 17:02:03)
    10. ACTION: jamoluhrsen to send mail about this moving of non-compliant tests out of distribution-test, patches are waiting for merge (colindixon, 17:02:31)
    11. instructions for signing gerrit commits per tykeal's instructions: https://git.opendaylight.org/gerrit/#/c/39378/ (colindixon, 17:02:49)
    12. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron? (colindixon, 17:03:11)
    13. ACTION: colindixon to send e-mail about possibly moving our documentation toolchain to ReStructured Text => Sphinx => Read The Docs, as opposed to using AsciiDoc => Asciidoctor, which has caused us some pain (colindixon, 17:03:16)
    14. ACTION: vishnoianil to add short versions of those questions here: https://wiki.opendaylight.org/view/Project_Proposals:Main#Instructions_for_Submitting_Creation_Review and/or the template here: https://wiki.opendaylight.org/view/Project_Proposals:ABC_Plugin (colindixon, 17:03:26)
    15. vishnoianil (vishnoianil, 17:04:00)
    16. Daniel Farrell (dfarrell07, 17:04:17)
    17. https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#June_20th tentative date for TWS on RESTCONF Draft 11 (colindixon, 17:04:18)
    18. two new agenda items: (1) ChrisPriceAB to formally accept the TSC chair elections, (2) Adding rgoulding to the security respone team (colindixon, 17:05:55)

  2. TSC Chair elections (colindixon, 17:06:01)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-May/005292.html the TSC chair nominations ended with ony one candidate: colindixon (colindixon, 17:06:43)
    2. VOTE: Voted on "Shall the TSC recognize and ratify Colin Dixon as the winner of the TSC Chair election for the Boron development cycle?" Results are, +1: 8 (ChrisPriceAB, 17:07:15)
    3. AGREED: the TSC ratifies colindixon as their chair for the Boron cycles. (ChrisPriceAB, 17:07:33)

  3. Giuseppe Petralia as NetIDE committer (colindixon, 17:08:08)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-May/005283.html (colindixon, 17:08:20)
    2. VOTE: Voted on "shall the TSC approve Giuseppe Petralia as a NetIDE committer?" Results are, +1: 7 (colindixon, 17:09:24)
    3. AGREED: Giuseppe Petralia is now a NetIDE committer (colindixon, 17:09:27)

  4. Ryan Goudling as a member of the security response team (colindixon, 17:09:44)
    1. https://wiki.opendaylight.org/view/Security_Advisories Ryan has fixed/reported two of the recent security advisories, and a few that haven't made it up there (colindixon, 17:10:34)
    2. rgoulding notes that one reason he wants to joing is to make things work (colindixon, 17:10:48)
    3. colindixon notes that he asked the security team to vote on this, there was one +1 and zeron -1s, now 3/4 +1s and no -1s (colindixon, 17:11:18)
    4. rovarga__ lost the voting mail, so +1 here :) (rovarga__, 17:11:40)
    5. edwarnicke votes +1 as an SRT member as well (colindixon, 17:11:52)
    6. edwarnicke also votes +1 in his capacity as security response member (edwarnicke, 17:12:02)
    7. VOTE: Voted on "shall the TSC approve rgoulding as a security response team member?" Results are, +1: 7 (colindixon, 17:12:24)
    8. mohnish__ also votes +1 (colindixon, 17:12:32)
    9. AGREED: Ryan Gouolding is now a Security Response team member (colindixon, 17:12:33)
    10. ACTION: rgoulding add your name ot the wik and open a helpdesk ticket to get your permissions (colindixon, 17:13:04)

  5. events (colindixon, 17:13:19)
    1. https://www.opendaylight.org/global-events (colindixon, 17:13:40)
    2. OPNFV sumit and ODL mini-summit aon 6/20 and 6/21 in berlin (colindixon, 17:14:18)
    3. hackfest 6/29 (colindixon, 17:14:28)
    4. ChrisPriceAB notes there will be a lot of people from lots of differnet places at the OPNFV summit: fd.io, ONOS CORD, ARM, and many more (colindixon, 17:15:21)
    5. go if you can (colindixon, 17:15:22)
    6. an OpenO meetup (colindixon, 17:15:26)

  6. boron (colindixon, 17:15:51)
    1. For M3 Offset 2, we are hosting an IRC meeting on Wednesday June 1st at 10:00AM Pacific Time Zone for new projects to ask questions about their M3 requirements. (anipbu, 17:16:11)
    2. https://lists.opendaylight.org/pipermail/release/2016-May/006638.html <--- M3 IRC Working Session (anipbu, 17:16:13)
    3. Neutron Northbound will be revising their neutron yang models and neutron spi to remove I*Aware(AD-SAL) API. Impacted projects include netvirt, GBP, VTN. (anipbu, 17:16:34)
    4. https://wiki.opendaylight.org/view/Weather#Neutron_Northbound:_neutron_yang_model_revise_and_I.2AAware.28AD-SAL.29_interface_removal <--- Weather Item for Neutron Northbound Revision (anipbu, 17:16:39)
    5. For the Restconf11 migration from Restconf02, there may be impact to End Users, Projects, CSIT Test Suite, with expected deprecation in Boron and removal in Carbon. (anipbu, 17:17:03)
    6. https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#June_20th <--- TWS Session on Restconf11 (anipbu, 17:17:05)
    7. https://lists.opendaylight.org/pipermail/release/2016-May/006634.html <--- Email discussing the impact of the Restconf11 Migration (anipbu, 17:17:10)
    8. colindixon notes that there will be no impact for restconf draft 11 in boron unless they want it to, it *may* be deprecated in boron, and it *may* be removed in carbon (colindixon, 17:18:29)
    9. restconf draft 11 and draft 02 should be able to coexist and so projects can use both simultaneously without issue (because they use different URI mount points) (colindixon, 17:18:56)
    10. We remind projects to include the sources when adding third party jars. (anipbu, 17:19:46)
    11. https://wiki.opendaylight.org/view/RelEng/Autorelease/Orbit <--- Third Party with Missing Sources (anipbu, 17:19:47)
    12. working with faas team to resolve autorelease breakages (anipbu, 17:20:06)
    13. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/lastFailedBuild/org.opendaylight.faas$features-faas/console <--- Latest Breakages as reported by Jenkins (anipbu, 17:20:13)
    14. zxiiro notes that we have some org.eclipse dependencies from 2007 and 2011, we should get rid of them if we can, edwarnicke and rovarga__ note that most of them should be able to be removed (colindixon, 17:21:21)
    15. ACTION: anipbu to open a bug and e-mail the controller team to see if somebody can remove the ancient org.eclipse dependenceis (colindixon, 17:22:27)
    16. rovarga__ notes that builds have been failing for most of the week b/c of the karaf upgrade and a few other things (colindixon, 17:23:24)
    17. it was a broken/buggy XML parser that came with Karaf 3.0.5 (colindixon, 17:24:05)

  7. system integration test (colindixon, 17:24:53)
    1. later today they will remove the system tests from distribution test if they don't pass consistnetly (colindixon, 17:25:22)
    2. this will give cleaner signals as to whether builds are clean or not (colindixon, 17:25:38)
    3. this is what's used for patch test jobs and pretty much all automated integration testing (colindixon, 17:25:55)

  8. infrastructure (colindixon, 17:26:06)
    1. last weekend we migrated the sandbox to the private cloud, there's been an issue with communcation between the public cloud and private cloud (colindixon, 17:26:45)
    2. it's possible that security updates on the routing hardware between the two clouds caused that issue, there is an issue open with rackspace now (colindixon, 17:27:20)
    3. pushing back migration of future stuff a week to make sure things are stable (colindixon, 17:27:34)
    4. rackspace notes that the firmware upgrade they did a few weeks ago will need anothe upgrade, hopefully downtime only this saturday in the AM pacific, but not sure yet (colindixon, 17:28:15)

  9. POTN creation review (colindixon, 17:29:00)
    1. https://wiki.opendaylight.org/view/Project_Proposals:POTN (colindixon, 17:29:09)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-May/005299.html creation review thread (colindixon, 17:29:20)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2016-March/000412.html proposed on 3/3/2016 (colindixon, 17:29:30)
    4. used to be called MPLS-TP Service (colindixon, 17:29:40)
    5. VOTE: Voted on "shall the TSC approve POTN as an incubation project?" Results are, +1: 7 (colindixon, 17:31:10)
    6. AGREED: POTN is an incubation project (colindixon, 17:31:16)
    7. VOTE: Voted on "shall the TSC allow POTN to join the Boron release at offset 2 if they want to given the delay was largely our fautl assuming they can meet the relevant milestones?" Results are, +1: 7 (colindixon, 17:32:52)
    8. AGREED: POTN can join Boron at offset 2 if they want and meet milestones (colindixon, 17:33:09)

  10. SPTN creation review (colindixon, 17:33:15)
    1. https://wiki.opendaylight.org/view/Project_Proposals:SPTN (colindixon, 17:33:15)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-May/005302.html creation review thread (colindixon, 17:33:16)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2016-March/000447.html proposed on 3/16/2016 (colindixon, 17:33:34)
    4. used to be called the MPLS-TP Solution project (colindixon, 17:33:45)
    5. VOTE: Voted on "shall the TSC approve SPTN project as an incubation project?" Results are, +1: 8 (colindixon, 17:34:43)
    6. VOTE: Voted on "shall the TSC allow SPTN to join the Boron release at offset 2 if they want to given the delay was largely our fautl assuming they can meet the relevant milestones?" Results are, +1: 8 (colindixon, 17:35:21)
    7. AGREED: the SPTN project is now an incubation project and can join boron at offset 2 if they want assuming they meet the milestones (colindixon, 17:35:39)

  11. Transport PCE creation review (colindixon, 17:35:50)
    1. https://wiki.opendaylight.org/view/Project_Proposals:TransportPCE (colindixon, 17:35:57)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2016-April/000495.html proposed on 4/28/2016 (colindixon, 17:36:21)
    3. https://wiki.opendaylight.org/images/8/8e/Transportpce_creation_review_v2.pdf slides (colindixon, 17:36:33)
    4. joint project proposal from orange, teliasonera, AT&T and one other (as-of-yet unnmaed) US telco (colindixon, 17:37:51)
    5. move to slide 4 (colindixon, 17:38:39)
    6. telco networks tend to be multi-layer with WDM, OTN and IP layers (colindixon, 17:39:11)
    7. WDM = wave division multiplexing, OTN = optical transport network (colindixon, 17:39:28)
    8. computing optimal multi-layer paths has bee difficult in the past (colindixon, 17:40:33)
    9. 1. there is a service request for a circuit, 2. look up topologies, 3. path caclutaion happens at multiple layers including bypassing the parts of the stack that aren't needed at each hop (e.g., the B router at the IP and OTN layers) 4. implement the path, 5. respond (colindixon, 17:42:12)
    10. the goal is to bring these paths up in seconds or minutes, not days/weeks/months (colindixon, 17:42:25)
    11. would also allow path optimization between layers, which isn't done today (colindixon, 17:42:50)
    12. moving to slide 5: Use Case #2: dynamic connectivity and capacity (colindixon, 17:43:28)
    13. basically doing bandwidth on demand and bandwidth calendaring (colindixon, 17:44:30)
    14. this basiclaly use case #1 with times that aren't now (colindixon, 17:45:21)
    15. there are other use cases where there is coordination with VNFs (colindixon, 17:45:41)
    16. use case 4: is multi-layer restoration (colindixon, 17:46:43)
    17. can fix failures at different time scales and do optimal routing again at multiple layers (colindixon, 17:47:33)
    18. slide 9: what is TransportPCE for? (colindixon, 17:48:44)
    19. jmedved asks what the RESTCONF interface between TransportPCE and SAL (colindixon, 17:56:03)
    20. https://wiki.opendaylight.org/view/Project_Proposals:TransportPCE#Scope (colindixon, 17:56:12)
    21. jmedved notes that this is really a RESTCONF interface between Transport PCE and the controller (colindixon, 17:57:22)
    22. xavier notes that Transport PCE will be a REST application, not in the JVM in Java (colindixon, 17:57:56)
    23. jmedved asks if there's an architecture diagram yet, xavier says no, not yet, jmedved offers to have a follow up meeting (colindixon, 17:58:22)
    24. slide 10 is a list of partners (colindixon, 17:59:08)
    25. jmedved asks which IGP is planned, xavier says it will be OSPF (colindixon, 18:00:04)
    26. rovarga asks if there is plan to integrate with BGP-LS, xavier says no for now because there is no BGP for ROADMs and others (colindixon, 18:00:52)
    27. colindixon asks if the repository name can be transportpce, answer is yes (colindixon, 18:02:00)
    28. VOTE: Voted on "shll the TSC approve the TransportPCE project as an incubation project?" Results are, +1: 8 (colindixon, 18:02:48)
    29. AGREED: Transport PCE is now an incubation project in OpenDaylight (colindixon, 18:03:13)
    30. they do not intend to join Boron (colindixon, 18:03:22)

  12. cookies (colindixon, 18:03:32)


Meeting ended at 18:03:41 UTC (full logs).

Action items

  1. phrobb and dfarrell07 to drive forward tooling and planning for the next TSC election
  2. jamoluhrsen to send mail about this moving of non-compliant tests out of distribution-test, patches are waiting for merge
  3. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
  4. colindixon to send e-mail about possibly moving our documentation toolchain to ReStructured Text => Sphinx => Read The Docs, as opposed to using AsciiDoc => Asciidoctor, which has caused us some pain
  5. vishnoianil to add short versions of those questions here: https://wiki.opendaylight.org/view/Project_Proposals:Main#Instructions_for_Submitting_Creation_Review and/or the template here: https://wiki.opendaylight.org/view/Project_Proposals:ABC_Plugin
  6. rgoulding add your name ot the wik and open a helpdesk ticket to get your permissions
  7. anipbu to open a bug and e-mail the controller team to see if somebody can remove the ancient org.eclipse dependenceis


Action items, by person

  1. anipbu
    1. anipbu to open a bug and e-mail the controller team to see if somebody can remove the ancient org.eclipse dependenceis
  2. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
    2. colindixon to send e-mail about possibly moving our documentation toolchain to ReStructured Text => Sphinx => Read The Docs, as opposed to using AsciiDoc => Asciidoctor, which has caused us some pain
  3. dfarrell07
    1. phrobb and dfarrell07 to drive forward tooling and planning for the next TSC election
  4. jamoluhrsen
    1. jamoluhrsen to send mail about this moving of non-compliant tests out of distribution-test, patches are waiting for merge
  5. rgoulding
    1. rgoulding add your name ot the wik and open a helpdesk ticket to get your permissions
  6. vishnoianil
    1. vishnoianil to add short versions of those questions here: https://wiki.opendaylight.org/view/Project_Proposals:Main#Instructions_for_Submitting_Creation_Review and/or the template here: https://wiki.opendaylight.org/view/Project_Proposals:ABC_Plugin


People present (lines said)

  1. colindixon (130)
  2. odl_meetbot (40)
  3. ChrisPriceAB (18)
  4. dfarrell07 (14)
  5. edwarnicke (13)
  6. vishnoianil (12)
  7. anipbu (11)
  8. abhijitkumbhare (10)
  9. mohnish__ (9)
  10. rovarga__ (8)
  11. tykeal (3)
  12. rgoulding (2)
  13. jmedved (1)
  14. zxiiro (1)
  15. Prem_ (1)
  16. jamoluhrsen (1)


Generated by MeetBot 0.1.4.