#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:04 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 18:00:10)
    1. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=52052#Agenda (colindixon, 18:00:17)
    2. edwarnicke (edwarnicke, 18:00:38)
    3. skitt (skitt, 18:00:40)
    4. anipbu (anipbu, 18:00:40)
    5. all new and returning TSC members, please #info in (colindixon, 18:00:42)
    6. colindixon (colindixon, 18:00:50)
    7. adetalhouet (adetalhouet, 18:01:02)
    8. Anil Vishnoi (vishnoianil, 18:01:12)
    9. Hideyuki Tai (hideyuki, 18:01:22)
    10. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-11-17-18.00.html last week's meeting minutes (colindixon, 18:01:36)
    11. jamoluhrsen (jamoluhrsen, 18:02:11)
    12. abhijitkumbhare (abhijitkumbhare, 18:02:27)
    13. shague (shague, 18:02:58)
    14. colindixon updated the list of ongoing mailing list discussions with OPNFV deliverables and managing projects with few/no active committers (colindixon, 18:03:39)
    15. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 18:03:46)
    16. ACTION: colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs (colindixon, 18:03:47)
    17. ACTION: colindixon to try to drive some/all of the ongoing TSC discussions to completion (colindixon, 18:03:48)
    18. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better (colindixon, 18:03:49)
    19. ACTION: colindixon and/or ChrisPriceAB to work on how to manage cross-release issues with ODL/OPNFV (colindixon, 18:03:50)
    20. we'll add a topic during updates on interns/mentors for 2017 (colindixon, 18:04:09)

  2. new TSC (colindixon, 18:04:42)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-November/006328.html (colindixon, 18:04:48)
    2. Returning: Abhijit Kumbhare, Alexis de Talhouet, Anil Vishnoi, Colin Dixon, Ed Warnicke, Luis Gomez (colindixon, 18:04:54)
    3. New: An Ho, Hideyuki Tai, Jamo Luhrsen, Robert Varga, Sam Hague, Stephen Kitt, Thanh Ha (colindixon, 18:05:08)
    4. LuisGomez (LuisGomez, 18:05:17)
    5. rovarga (rovarga, 18:05:20)
    6. Departing: Chris Price, Daniel Farrell (Chris Wright), Gideon Kaempfer, Jan Medved, Uri Elzur (colindixon, 18:05:21)
    7. colindixon says he'd like to deeply thank those people for all their hard work on the TSC (colindixon, 18:06:19)
    8. https://www.opendaylight.org/governance/ everyone seems to be listed here (thanks CaseyODL) (colindixon, 18:06:34)
    9. ACTION: phrobb to send out mail calling for nominations for TSC chair and then kick of an election (colindixon, 18:12:14)
    10. phrobb notes that the only people who can nominate themselves and vote in the election are TSC members (colindixon, 18:12:53)
    11. Thanh (zxiiro, 18:13:53)
    12. colindixon says that he hopes that we could close this before the holidays, given that we're down to 13 people we could do this quickly (colindixon, 18:14:01)
    13. VOTE: Voted on "are people OK having a 1 week nomination period and 1 week voting period back-to-back, starting now?" Results are, +1: 13 (colindixon, 18:15:02)
    14. AGREED: nominations for TSC chair open now, phrobb will post a wiki page immediately after this meeting, nominations close at 23:59 UTC on Wednesday 12/7, voting will start on 12/8 and close at 23:59 UTC on 12/14 (colindixon, 18:15:56)

  3. committer-at-large representavies on the board (colindixon, 18:16:26)
    1. https://wiki.opendaylight.org/view/Committer_Members_Board_Representation Link to how the process works (colindixon, 18:17:07)
    2. https://linuxfoundation.echosign.com/public/hostedForm?formid=AI3XA256U2H44Y Link to form to become a committer member (phrobb, 18:18:26)
    3. https://wiki.opendaylight.org/view/Interns/Summer_2015#Improved_ODL_Meetbot (colindixon, 18:19:12)
    4. ACTION: phrobb will open the nominations for comitter-at-large board representatives next week, this week is for sigining to be a committer member of the ODL non-profit (colindixon, 18:20:03)
    5. 2 week nominations ~12/7 to ~12/21, voting will be in the new year ~1/2 to ~1/16 (colindixon, 18:20:43)

  4. TSC mailing list votes and discussions (colindixon, 18:21:14)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-November/006383.html Vote on ALTO committers—will close after today's TSC call (colindixon, 18:21:24)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-November/006368.html projects with few/no active committers (colindixon, 18:22:11)
    3. https://lists.opendaylight.org/pipermail/tsc/2016-November/006298.html Delivering to consumer project off-cadence (ODP & OPNFV collaboration) (colindixon, 18:22:33)
    4. https://lists.opendaylight.org/pipermail/tsc/2016-December/006392.html escalation process we have in OpenDaylight has been added to the TSC page (object now if you want to) (colindixon, 18:23:12)
    5. ACTION: phrobb to log the DDF attendance policy in the TSC Procedures and Policies section, so that we have it for future (colindixon, 18:24:13)
    6. https://lists.opendaylight.org/pipermail/tsc/2016-December/006389.html only allow blocking bug fixes after RCs start in Carbon (colindixon, 18:24:33)
    7. ACTION: colindixon to remove many current discussions which are now closed, which is a lot of them (colindixon, 18:26:32)
    8. https://lists.opendaylight.org/pipermail/tsc/2016-December/006388.html Categorizing projects (please add your project type to your project facts sidebar) (colindixon, 18:28:29)

  5. 2017 OpenDaylight Interns (colindixon, 18:28:51)
    1. https://wiki.opendaylight.org/view/InternProjects:Main please propose projects here (colindixon, 18:29:17)
    2. CaseyODL wants to have things come up tomorrow (colindixon, 18:29:33)
    3. CaseyODL plans ot advertise it on Monday (colindixon, 18:30:08)
    4. CaseyODL notes that he's been asking for projects for a month (colindixon, 18:31:09)
    5. colindixon notes that you can add more topics after monday, but interns applying might not know about your project if they look before you list it (colindixon, 18:31:48)
    6. dfarrell07 and CaseyODL say that we need to get it advertised on Monday to try to avoid losing good candidates to other programs (colindixon, 18:32:52)
    7. colindixon has listed a lot with "Mentors: ???? and Colin Dixon <colin@colindixon.com>" if you want to help do one, please please please help (colindixon, 18:34:13)
    8. CaseyODL notes that the LF pays for the interns, these are free interns (colindixon, 18:34:24)
    9. vishnoianil asks if project-specific projects are allowed, or does it have to be cross-project, CaseyODL says that pretty much anything that benefits ODL will be allowed (colindixon, 18:36:27)

  6. events (colindixon, 18:37:34)
    1. https://www.opendaylight.org/global-events (colindixon, 18:37:46)
    2. https://www.opendaylight.org/events/2016-12-05-000000-2016-12-09-000000/opnfv-plugfest December 5, 2016 OPNFV Plugfest Durham, New Hampshire (colindixon, 18:38:07)
    3. December 7, 2016 Global Network Technology Conference Beijing, China (colindixon is speaking) (colindixon, 18:38:21)
    4. December 12, 2016 ODL China City Tour Nanjing, Beijing, Shenzhen and Shanghai (at least phrobb, Lisa Caywood, Neela are all going) (colindixon, 18:38:48)
    5. phrobb talks about the "Leadership Summit", which is in Tahoe in the first week of February, should we try to get some TSCs together from different LF projects (colindixon, 18:40:45)
    6. phrobb asks if there's interest (colindixon, 18:41:24)
    7. at least jamoluhrsen, abhijitkumbhare, jamoluhrsen, colindixon, edwarnicke, dfarrell07 all say this is a good idea (colindixon, 18:42:34)
    8. ACTION: phrobb to follow up with LF folks about a TSC mixer at the Leadership Summit (colindixon, 18:43:09)

  7. boron (colindixon, 18:43:47)
    1. https://lists.opendaylight.org/pipermail/release/2016-December/008829.html <--- Boron SR2 Release Date: December 15; Cutoff Date on December 11 at 23:59 UTC (anipbu, 18:44:07)
    2. https://lists.opendaylight.org/pipermail/release/2016-December/008818.html <--- Boron Autorelease Build Failure (anipbu, 18:44:17)
    3. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&f1=cf_target_milestone&f2=cf_target_milestone&j_top=OR&list_id=67733&o1=substring&o2=substring&query_format=advanced&resolution=---&v1=Boron&v2=--- <--- One blocker bug in openflowplugin (anipbu, 18:44:31)
    4. https://git.opendaylight.org/gerrit/#/q/status:open+branch:stable/boron <--- 32 patches pending for stable/boron (anipbu, 18:44:51)
    5. https://git.opendaylight.org/gerrit/#/dashboard/?title=Boron+Status&Yang+File+Changes+Since+Boron+SR1=branch:stable/boron+status:merged+file:%22%255E.%252Byang%22+after:2016-10-27 <--- 23 patches modifying yang files without API Freeze Waiver between Boron SR1 and Boron SR2 (anipbu, 18:45:07)

  8. carbon (colindixon, 18:45:31)
    1. https://wiki.opendaylight.org/view/Weather#Change_in_yangtools.27s_yang-model-api <--- Changes to DocumentedNode. Method getStatus() was moved from the interface DocumentedNode into the WithStatus interface. (anipbu, 18:45:46)
    2. https://git.opendaylight.org/gerrit/#/c/48246/ <--- DocumentedNode changes merged. (anipbu, 18:46:03)
    3. https://wiki.opendaylight.org/view/Weather#Change_in_yangtools.27s_RpcStatement <--- Changes to RpcStatement. Empty input and output statements are now automatically added to every rpc statement that does not define them. (anipbu, 18:46:12)
    4. https://git.opendaylight.org/gerrit/#/c/48704/ <--- RpcStatement changes pending code review. (anipbu, 18:46:26)
    5. https://wiki.opendaylight.org/view/Weather#Change_in_yangtools.27s_DataTreeConfiguration <--- Changes to DataTreeConfiguration. Data tree configuration for operational data tree now enforces validation of mandatory nodes. (anipbu, 18:46:37)
    6. https://git.opendaylight.org/gerrit/#/c/48672/ <--- DataTreeConfiguration changes pending. (anipbu, 18:46:47)
    7. colindixon asks if they've run CSIT tests against 48672, rovarga says not yet, but they will befoore merging it (colindixon, 18:49:36)
    8. https://lists.opendaylight.org/pipermail/release/2016-December/008828.html <--- Carbon M2 Offset 1 Status is due Today 12/1. (anipbu, 18:49:50)
    9. Carbon M2 IRC Working Session for new projects on Wednesday 12/7/2016 7:30AM Pacific Time Zone (anipbu, 18:49:57)
    10. https://lists.opendaylight.org/pipermail/release/2016-December/008827.html <--- CENTINEL Carbon Autorelease Build Failure (anipbu, 18:50:20)
    11. Last Successful Carbon Autorelease Build on November 17, 2016 (anipbu, 18:50:30)

  9. system integration and testing (colindixon, 18:50:59)
    1. infrastructure resource collaboration inititiave with other projects in the LF, dfarrell07 and LuisGomez are participating (colindixon, 18:52:10)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Features <--- definition of top level, user facing features (jamoluhrsen, 18:52:47)

  10. infrastructure (colindixon, 18:53:15)
    1. big outage last weekend lasted 10 hours: fixed a battery, upgraded from kilo to liberty (colindixon, 18:53:15)
    2. we did run into problems now bubbling up in the last few days with lost ports, but they seem to all be resolved now (colindixon, 18:53:42)

  11. APAC time-zone TSC calls (colindixon, 18:54:44)
    1. http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f447623d29817bc7 poll results (colindixon, 18:55:01)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-October/006125.html (colindixon, 18:55:10)
    3. jamoluhrsen asks if we need quorum, colindixon says probably yes for it to be useful (colindixon, 18:58:57)
    4. vishnoianil asks if we get no participation, will we change it again, yeah that makes sense (colindixon, 18:59:15)
    5. two obvious time slots (at least to colindixon) (colindixon, 19:00:02)
    6. https://www.timeanddate.com/worldclock/meetingdetails.html?year=2016&month=7&day=21&hour=3&min=30&sec=0&p1=771&p2=33&p3=248&p4=283&p5=263&p6=37 (colindixon, 19:00:09)
    7. https://www.timeanddate.com/worldclock/meetingdetails.html?year=2016&month=7&day=21&hour=7&min=0&sec=0&p1=771&p2=33&p3=248&p4=283&p5=263&p6=37 (colindixon, 19:00:15)
    8. abhijitkumbhare notes that the times might shift for countries with daylight savings time (colindixon, 19:02:30)
    9. ACTION: colindixon to start a thread to get candidate times and then we can figure out how to vote after that, at least (colindixon, 19:04:03)

  12. cookies (colindixon, 19:04:31)


Meeting ended at 19:04:34 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  3. colindixon to try to drive some/all of the ongoing TSC discussions to completion
  4. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
  5. colindixon and/or ChrisPriceAB to work on how to manage cross-release issues with ODL/OPNFV
  6. phrobb to send out mail calling for nominations for TSC chair and then kick of an election
  7. phrobb will open the nominations for comitter-at-large board representatives next week, this week is for sigining to be a committer member of the ODL non-profit
  8. phrobb to log the DDF attendance policy in the TSC Procedures and Policies section, so that we have it for future
  9. colindixon to remove many current discussions which are now closed, which is a lot of them
  10. phrobb to follow up with LF folks about a TSC mixer at the Leadership Summit
  11. colindixon to start a thread to get candidate times and then we can figure out how to vote after that, at least


Action items, by person

  1. ChrisPriceAB
    1. colindixon and/or ChrisPriceAB to work on how to manage cross-release issues with ODL/OPNFV
  2. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
    3. colindixon to try to drive some/all of the ongoing TSC discussions to completion
    4. colindixon and/or ChrisPriceAB to work on how to manage cross-release issues with ODL/OPNFV
    5. colindixon to remove many current discussions which are now closed, which is a lot of them
    6. colindixon to start a thread to get candidate times and then we can figure out how to vote after that, at least
  3. phrobb
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
    3. phrobb to send out mail calling for nominations for TSC chair and then kick of an election
    4. phrobb will open the nominations for comitter-at-large board representatives next week, this week is for sigining to be a committer member of the ODL non-profit
    5. phrobb to log the DDF attendance policy in the TSC Procedures and Policies section, so that we have it for future
    6. phrobb to follow up with LF folks about a TSC mixer at the Leadership Summit
  4. tykeal
    1. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
  5. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs


People present (lines said)

  1. colindixon (93)
  2. anipbu (19)
  3. vishnoianil (10)
  4. abhijitkumbhare (10)
  5. rovarga (8)
  6. skitt (7)
  7. odl_meetbot (7)
  8. tykeal (6)
  9. jamoluhrsen (6)
  10. adetalhouet (5)
  11. dfarrell07 (5)
  12. edwarnicke (4)
  13. shague (3)
  14. ChrisPriceAB (3)
  15. zxiiro (3)
  16. CaseyODL (3)
  17. LuisGomez (2)
  18. hideyuki (2)
  19. phrobb (2)


Generated by MeetBot 0.1.4.