#opendaylight-meeting: TSC

Meeting started by colindixon at 18:00:40 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 18:00:46)
    1. colindixon (colindixon, 18:00:52)
    2. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=52940#Agenda (colindixon, 18:01:05)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-02-02-18.00.html last week's meeting minutes (colindixon, 18:01:19)
    4. LuisGomez (LuisGomez, 18:01:33)
    5. abhijitkumbhare (abhijitkumbhare, 18:01:40)
    6. jamoluhrsen (jamoluhrsen, 18:01:42)
    7. Anil Vishnoi (vishnoianil, 18:01:44)
    8. rovarga (rovarga, 18:01:49)
    9. hideyuki (hideyuki, 18:02:03)
    10. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 18:02:14)
    11. ACTION: colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs (colindixon, 18:02:15)
    12. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 18:02:16)
    13. ACTION: colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia (colindixon, 18:02:17)
    14. skitt (skitt, 18:02:36)
    15. ACTION: anipbu will add a field for the spreadsheet/bugs on autorelease failures with short root cause analysis of how it got through verify without breaking (colindixon, 18:03:03)

  2. Katie will be the new ODL Release manager (colindixon, 18:05:12)
    1. shague (shague, 18:05:42)
    2. Katie will be replacing An as the release manager for OpenDaylight, expect the e-mails that woudl come from An to come from her instead (colindixon, 18:05:47)
    3. Thanh (zxiiro, 18:05:47)
    4. anipbu will still be a TSC member and broadly involved (colindixon, 18:06:07)
    5. colindixon says it would be almost impossible to overstate how important anipbu has been to OpenDayligth over the last year or so (colindixon, 18:06:52)

  3. carbon readout (colindixon, 18:08:31)
    1. Missing M3 Status from snmp,atrium,capwap,cardinal,centinel,didm,eman,integration/distribution,iotdm,lacp,natapp,netide,next,of-config,opflex,sdninterfaceapp,snbi,usecplugin,vpnservice,yang-push,yangide (colindixon, 18:08:35)
    2. note that snmp is the only one from offset 1 and nobody is from offset 0 has failed to send it out (colindixon, 18:09:05)
    3. for offset 0, we only have an M4 readout from odlparent, all others are currently missing (colindixon, 18:09:29)
    4. https://wiki.opendaylight.org/view/Weather#Detection_of_identifier_collisions_according_to_RFC_6020_.2F_RFC_7950 <--- Extends current detection of identifier collisions (colindixon, 18:09:37)

  4. boron (colindixon, 18:10:33)
    1. nothing this week (colindixon, 18:10:36)

  5. next week's TSC call (colindixon, 18:10:52)
    1. should we have one during the leadership summit (colindixon, 18:11:06)
    2. overlaps with two kenotes https://osleadershipsummit2017.sched.com/event/9Jzh (colindixon, 18:11:16)
    3. one keynote has Neela speaking https://osleadershipsummit2017.sched.com/event/9Jzj/keynote-collaborative-project-updates-odp-cncf-openswitch-cii (colindixon, 18:11:33)
    4. VOTE: Voted on "will you be in tahoe next week?" Results are, yes: 6, no: 5 (colindixon, 18:12:53)
    5. VOTE: Voted on "shall the TSC cancle next week's (2/16/17) TSC call?" Results are, +1: 10 (colindixon, 18:14:16)
    6. AGREED: there will be no TSC meeting next week (colindixon, 18:14:38)
    7. ACTION: phrobb to set up a phone bridge for remote participation at the TSC mixer and send that out to the TSC members (colindixon, 18:14:56)

  6. TSC mailing list votes and discussions (colindixon, 18:15:11)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-February/006577.html Nitrogen planning (colindixon, 18:15:24)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-February/006581.html Namespace management (colindixon, 18:15:37)
    3. https://lists.opendaylight.org/pipermail/tsc/2017-February/006578.html projects with few/no active committers (colindixon, 18:16:11)
    4. https://lists.opendaylight.org/pipermail/release/2017-January/009034.html flagship features in Carbon (colindixon, 18:16:19)
    5. https://lists.opendaylight.org/pipermail/tsc/2017-February/006579.html dropping Carbon hackfest date/location (colindixon, 18:16:30)
    6. https://lists.opendaylight.org/pipermail/tsc/2017-February/006580.html dropping off-cycle releases (colindixon, 18:16:54)
    7. ACTION: colindixon to remove carbon hackfest and off-cycle releases from discussions list on next week's agenda (colindixon, 18:17:24)
    8. https://lists.opendaylight.org/pipermail/release/2017-February/009226.html [release] deprecate port 8080 (or 8181) so we only bring up one port? (colindixon, 18:18:09)

  7. Karaf 4 upgrade (colindixon, 18:18:38)
    1. we've progressed as far as NETCONF (colindixon, 18:18:44)
    2. rovarga says that we're looking at some issues in AAA (colindixon, 18:18:55)
    3. most projects are blocked on dlux needing Karaf 4 features for downstreams, the patch is ready, but hasn't been merged (colindixon, 18:19:35)
    4. ACTION: colindixon will try to scare up a dlux committer to merge the karaf 4 patch (colindixon, 18:20:33)
    5. offset 1 and 2 projects should start the migration (colindixon, 18:20:40)
    6. ACTION: katie to start tracking karaf 4 on the tracking spreadsheet with help from anipbu if needed (colindixon, 18:21:16)
    7. https://bugs.opendaylight.org/showdependencytree.cgi?id=4219&hide_resolved=1 (rovarga, 18:21:48)
    8. dependency tree for the Karaf 4 migration: https://bugs.opendaylight.org/showdependencytree.cgi?id=4219&hide_resolved=1 (skitt, 18:21:52)
    9. patches: https://git.opendaylight.org/gerrit/#/q/topic:karaf4 (rovarga, 18:22:05)
    10. ACTION: vrpolak to start thinking about how to create a karaf 4 distribtion and when, maybe send mail (colindixon, 18:23:03)

  8. events (colindixon, 18:23:17)
    1. https://www.opendaylight.org/global-events (colindixon, 18:23:25)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 18:23:51)
    3. https://wiki.opendaylight.org/view/Events:Main#ODL_Nitrogen_Developer_Design_Forum we are locking down the Nitrogen DDF date for 5/31/17 and 6/1/17 (colindixon, 18:24:48)
    4. https://wiki.opendaylight.org/view/Events:Main#OPNFV_Summit OPNFV summit in beijing's CFP will open next week, we're pretty sure (colindixon, 18:25:23)
    5. leadership summit in Tahoe next week (colindixon, 18:25:49)
    6. the expectation is to have notices out to all accepted ONS presenters by the end of the month (colindixon, 18:26:10)
    7. the OpenStack CFP has been left open until today, so please submit if you haven't (colindixon, 18:26:30)

  9. system integration and test (colindixon, 18:26:50)
    1. now that we've moved jobs to running only 5 days a week, makes infrastructure issues more noticeable at times (colindixon, 18:27:29)
    2. jamoluhrsen says that they're looking into trying to debug that with rackspace (colindixon, 18:28:04)
    3. jamoluhrsen says they're trying to retry on failures, but LuisGomez has pointed out that's just maksing issues rackspace is having (colindixon, 18:28:54)

  10. infrastructure (colindixon, 18:29:16)
    1. yesterday, we noticed that rackspace was sending 503 errors to our CSIT jobs when we tried to spawn some things, rackspace says it's fixed, but jamoluhrsen says maybe not, let zxiiro and others know on the mailing list if we still see them (colindixon, 18:29:58)
    2. https://git.opendaylight.org/gerrit/51096 Autorelease Auto Notify Patch (zxiiro, 18:30:12)
    3. we're working on a patch to make autorelease notify projects when the build breaks (colindixon, 18:30:33)

  11. nitrogen planning (colindixon, 18:31:07)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-February/006577.html (colindixon, 18:31:18)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-July/005665.html previous thead on twice per year release process (colindixon, 18:33:06)
    3. skitt points out that colindixon's naive idea of just publishing a version on each merge is the same as SNAPSHOTs (colindixon, 18:35:24)
    4. skitt then says what we really need is some way to actually define what semantic versioning is and then how we will do that (colindixon, 18:35:55)
    5. rovarga notes that yang tools has things they want to do in a v2.0 release, but doing so somewhat breaks the autorelease release model (colindixon, 18:36:33)
    6. rovarg and skitt seem to think that we need to be able to have multiple branches; each with a different release train; and also need to have all projects move to a release-based model (colindixon, 18:38:46)
    7. skitt says that he thinks there is something good to do here, but we can start with odlparent, yangtools, and maybe mdsal, which would give a good playground (colindixon, 18:41:58)
    8. rovarga notes that we need to start with when we cut the carbon stability branches (colindixon, 18:42:26)
    9. skitt says that you can always fix that later (colindixon, 18:42:38)
    10. ACTION: colindixon to set up some kind fo meeting (or at least thead) about semantic-versioning-ish things for nitrogen (colindixon, 18:43:13)

  12. cookies (colindixon, 18:44:27)


Meeting ended at 18:44:45 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  3. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  4. colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia
  5. anipbu will add a field for the spreadsheet/bugs on autorelease failures with short root cause analysis of how it got through verify without breaking
  6. phrobb to set up a phone bridge for remote participation at the TSC mixer and send that out to the TSC members
  7. colindixon to remove carbon hackfest and off-cycle releases from discussions list on next week's agenda
  8. colindixon will try to scare up a dlux committer to merge the karaf 4 patch
  9. katie to start tracking karaf 4 on the tracking spreadsheet with help from anipbu if needed
  10. vrpolak to start thinking about how to create a karaf 4 distribtion and when, maybe send mail
  11. colindixon to set up some kind fo meeting (or at least thead) about semantic-versioning-ish things for nitrogen


Action items, by person

  1. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
    3. colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia
    4. colindixon to remove carbon hackfest and off-cycle releases from discussions list on next week's agenda
    5. colindixon will try to scare up a dlux committer to merge the karaf 4 patch
    6. colindixon to set up some kind fo meeting (or at least thead) about semantic-versioning-ish things for nitrogen
  2. phrobb
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
    3. phrobb to set up a phone bridge for remote participation at the TSC mixer and send that out to the TSC members
  3. tykeal
    1. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  4. vishnoianil
    1. colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia
  5. vrpolak
    1. vrpolak to start thinking about how to create a karaf 4 distribtion and when, maybe send mail
  6. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  7. UNASSIGNED
    1. anipbu will add a field for the spreadsheet/bugs on autorelease failures with short root cause analysis of how it got through verify without breaking
    2. katie to start tracking karaf 4 on the tracking spreadsheet with help from anipbu if needed


People present (lines said)

  1. colindixon (81)
  2. odl_meetbot (14)
  3. jamoluhrsen (9)
  4. rovarga (8)
  5. abhijitkumbhare (7)
  6. zxiiro (5)
  7. vishnoianil (5)
  8. skitt (4)
  9. LuisGomez (4)
  10. dfarrell07 (4)
  11. tykeal (3)
  12. shague (3)
  13. hideyuki (3)
  14. phrobb (2)
  15. vrpolak (1)
  16. CaseyODL (1)


Generated by MeetBot 0.1.4.