#opendaylight-meeting: tsc

Meeting started by colindixon at 03:30:18 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 03:30:23)
    1. colindixon (colindixon, 03:30:33)
    2. Thanh (zxiiro, 03:30:45)
    3. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=57876#Agenda (colindixon, 03:30:46)
    4. anipbu (anipbu, 03:30:48)
    5. huan (huan, 03:30:55)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-06-15-17.00.html Last meeting's minutes (colindixon, 03:30:58)
    7. jamoluhrsen (jamoluhrsen, 03:31:11)
    8. abhijitkumbhare (abhijitkumbhare, 03:31:38)
    9. ACTION: phrobb to bring the need for a security manager to the board (colindixon, 03:31:45)
    10. ACTION: phrobb to float the idea of hiring a Karaf consultant to the board (colindixon, 03:31:45)
    11. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 03:31:47)
    12. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 03:31:48)
    13. ACTION: colindixon to look to see if any current security response team members would like to voluntarily step down for any reason (colindixon, 03:31:48)
    14. ACTION: colindixon should reach out to projects and see if we can't archive some of them (colindixon, 03:32:32)
    15. ACTION: rovarga to reach out to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller (colindixon, 03:33:14)
    16. ACTION: colindixon to reach out to gidi to try to get them merged and maybe mint new committers (colindixon, 03:33:25)
    17. Hideyuki (hideyuki, 03:33:33)
    18. vine_ermagan (proxy for lori) (vina_ermagan, 03:33:43)
    19. Anil vishnoi (vishnoianil, 03:33:50)
    20. vina_ermagan] (vina_ermagan, 03:34:04)

  2. TSC mailing list votes and discussion (colindixon, 03:34:50)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html release manager job description and call for volunteers (colindixon, 03:35:17)
    2. VOTE: Voted on "shall the TSC create a formal (currently vacant) position for release manager with the job description linked here: https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html?" Results are, +1: 8 (colindixon, 03:36:56)
    3. AGREED: the TSC creates a formal (currently vacant) position for release manager with the job description linked here: https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html (colindixon, 03:37:25)
    4. LuisGomez (LuisGomez, 03:37:58)
    5. abhijitkumbhare asks if this is a program manager vs. release manager, anipbu says maybe (colindixon, 03:38:21)
    6. https://lists.opendaylight.org/pipermail/tsc/2017-June/007506.html future developer design forums (colindixon, 03:39:01)
    7. ACTION: CaseyODL to follow up on this discussion about what we would do to poll people about what would encourage attendance at future DDFs (colindixon, 03:40:23)

  3. events (colindixon, 03:40:49)
    1. https://www.opendaylight.org/global-events (colindixon, 03:40:58)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 03:41:04)
    3. no other major events going on, at OPNFV summit there was a live, main-stage demo of vCO with OPNFV and OpenDaylight, the OPNFV summit went well (colindixon, 03:42:23)

  4. Boron (colindixon, 03:43:14)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/SR4/Status <--- We would like to present to the TSC and OpenDaylight community the final build for Boron SR4 Build 20170615. (anipbu, 03:43:39)
    2. Though we will unlock the branch, please note that SR4 is the last regularly scheduled SR for Boron. (anipbu, 03:44:12)
    3. VOTE: Voted on "shall the TSC release Boron-SR4 per the notes above?" Results are, +1: 9 (colindixon, 03:46:51)
    4. AGREED: Boron-SR4 has been released (colindixon, 03:47:02)

  5. Carbon (colindixon, 03:47:30)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule <--- Carbon SR1 scheduled for 7/6/2017 with a cutoff on Sunday 7/2/2017 at 23:59 UTC (anipbu, 03:47:45)
    2. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 <--- 2 Carbon SR1 Blocker in netvirt, sfc (anipbu, 03:48:11)

  6. nitrogen (colindixon, 03:48:41)
    1. https://lists.opendaylight.org/pipermail/release/2017-June/011338.html <--- Nitrogen M0 Offset 2 due today 6/21 (anipbu, 03:48:58)
    2. https://lists.opendaylight.org/pipermail/release/2017-June/011306.html <--- odlparent version 2.0.0 artifacts has been released and available on nexus (anipbu, 03:49:15)
    3. https://lists.opendaylight.org/pipermail/release/2017-June/011307.html <--- Projects must migrate to odlparent version 2.0.0 (anipbu, 03:49:23)
    4. https://lists.opendaylight.org/pipermail/release/2017-June/011299.html <--- Karaf 4 Migration Status and Plan of Action including per project Nitrogen Karaf 4 Requirements (anipbu, 03:49:32)
    5. we're currently blocked on netconf migrating to odlparent-2.0.0 https://git.opendaylight.org/gerrit/#/c/59284/ (colindixon, 03:50:34)

  7. system integration and test (colindixon, 03:51:15)
    1. we will now make boron jobs run weekly, which should help queues (colindixon, 03:51:34)
    2. jamoluhrsen says that he's seeing some projects testing their karaf 4 distributions in CSIT and that's seeing some success (colindixon, 03:52:15)
    3. that's good! (colindixon, 03:52:21)
    4. LuisGomez says that we're currently basically ignoring integration/distribution until offset 0 projects have merged their odlparent-2.0.0 patches, currently waiting on aaa and netconf (colindixon, 03:53:21)

  8. infrastructure (colindixon, 03:53:55)
    1. https://access.redhat.com/security/vulnerabilities/stackguard Stack Guard (zxiiro, 03:54:13)
    2. we did a lot of reboots of stuff yesterday to patch because of stack guard vulnerability (colindixon, 03:54:23)

  9. Bier App (colindixon, 03:55:52)
    1. https://wiki.opendaylight.org/view/Project_Proposals:BIER_APP (colindixon, 03:56:07)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2017-June/000578.html Proposed on 6/5/2017 (colindixon, 03:56:57)
    3. https://wiki.opendaylight.org/view/File:Presentation-bierapp-proposal-review.pdf slides here (colindixon, 03:57:09)
    4. abhijitkumbhare asks why this needs to be separate project from the bier project? vina_ermagan asks the same thing. (colindixon, 04:03:07)
    5. https://lists.opendaylight.org/pipermail/project-proposals/2017-June/000583.html colindixon asked the same question on the mailing list (colindixon, 04:04:14)
    6. the response was: "Xiong RE: We still want to separate the BIER plugin and applications and do our best to guarantee the independence between the two projects." (colindixon, 04:05:58)
    7. anipbu notes the same issues above (colindixon, 04:07:27)
    8. vina_ermagan asks if the BIER_APP could do anything without the BIER plugin, the answer seems to be no, it can't (colindixon, 04:07:47)
    9. vina_ermagan notes that in LISP flow mapping they have a GUI and a plugin in the same project (colindixon, 04:08:18)
    10. colindixon suggests that even if the code is resident in the same git repository as BIER, but it the APP could be independent and be run without OpenDaylight, e.g., on another controller with same APIs (colindixon, 04:10:50)
    11. vishnoianil and colindixon point out NetVirt and OVSDB split, so this isn't without precedent (colindixon, 04:13:02)
    12. abhijitkumbhare and anipbu advocate for starting with one project and then splitting if need be, vishnoianil notes that splitting was harder than you might hope (colindixon, 04:14:20)
    13. anipbu asks if we could change the git repository from bier_app to bierapp to avoid special characters (colindixon, 04:19:51)
    14. VOTE: Voted on "assuming that they still want to have a separate project for BIER_APP in a week's time, does the TSC approve the project as an incubation project and pending a possible technically-justified git repo name?" Results are, 0: 3, +1: 7 (colindixon, 04:22:31)
    15. AGREED: assuming that they still want to have a separate project for BIER_APP in a week's time, does the TSC approve the project as an incubation project and pending a possible technically-justified git repo name (colindixon, 04:23:03)

  10. p4 plugin creation review (colindixon, 04:24:19)
    1. https://wiki.opendaylight.org/view/Project_Proposals:P4_Plugin (colindixon, 04:24:45)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2017-June/000580.html Proposed on 6/7/2017 (colindixon, 04:25:16)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2017-June/000586.html (colindixon, 04:29:32)
    4. colindixon notes that the P4 Plugin are looking to join Oxygen, not Nitrogen (colindixon, 04:31:05)
    5. https://lists.opendaylight.org/pipermail/project-proposals/2017-June/000586.html for P4 plugin's statement (colindixon, 04:31:08)
    6. https://lists.opendaylight.org/pipermail/project-proposals/2017-June/000587.html says that BIER_APP does plan to be in nitrogen (colindixon, 04:31:46)
    7. https://p4lang.github.io/p4-spec/ P4 spec (colindixon, 04:32:11)
    8. abhijitkumbhare asks if there is a way to attach OpenFlow to P4 and how does OpenFlow relate to P4 (colindixon, 04:34:43)
    9. VOTE: Voted on "shall the TSC approve the P4 project as an incubation project?" Results are, +1: 9 (colindixon, 04:34:58)
    10. AGREED: P4 Plugin is now an incubation project in OpenDaylight (colindixon, 04:35:17)

  11. cookies (colindixon, 04:35:31)


Meeting ended at 04:35:46 UTC (full logs).

Action items

  1. phrobb to bring the need for a security manager to the board
  2. phrobb to float the idea of hiring a Karaf consultant to the board
  3. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  4. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  5. colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
  6. colindixon should reach out to projects and see if we can't archive some of them
  7. rovarga to reach out to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller
  8. colindixon to reach out to gidi to try to get them merged and maybe mint new committers
  9. CaseyODL to follow up on this discussion about what we would do to poll people about what would encourage attendance at future DDFs


Action items, by person

  1. CaseyODL
    1. CaseyODL to follow up on this discussion about what we would do to poll people about what would encourage attendance at future DDFs
  2. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
    3. colindixon should reach out to projects and see if we can't archive some of them
    4. colindixon to reach out to gidi to try to get them merged and maybe mint new committers
  3. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  4. UNASSIGNED
    1. phrobb to bring the need for a security manager to the board
    2. phrobb to float the idea of hiring a Karaf consultant to the board
    3. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
    4. rovarga to reach out to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller


People present (lines said)

  1. colindixon (94)
  2. odl_meetbot (23)
  3. anipbu (14)
  4. vishnoianil (11)
  5. vina_ermagan (9)
  6. jamoluhrsen (8)
  7. abhijitkumbhare (8)
  8. zxiiro (6)
  9. hideyuki (6)
  10. huan (6)
  11. LuisGomez (4)
  12. CaseyODL (1)


Generated by MeetBot 0.1.4.