#opendaylight-meeting: TSC

Meeting started by colindixon at 17:00:15 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:20)
    1. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=64435#Agenda (colindixon, 17:00:50)
    2. linking in minutes from the past 3 meetings (including split notes for one meeting) to catch action items (colindixon, 17:01:01)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-17-17.02.html (colindixon, 17:01:02)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-17-17.48.html (colindixon, 17:01:03)
    5. LuisGomez (LuisGomez, 17:01:03)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-24-03.28.html (colindixon, 17:01:04)
    7. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-31-17.03.html (colindixon, 17:01:05)
    8. edwarnicke (edwarnicke, 17:01:07)
    9. anipbu (anipbu, 17:01:08)
    10. colindixon (colindixon, 17:01:09)
    11. Thanh (zxiiro, 17:01:17)
    12. https://lists.opendaylight.org/pipermail/tsc/2017-September/007890.html colindixon sent mail to TSC about Carbon-SR2 (colindixon, 17:01:28)
    13. CaseyODL should have fixed Zoom recording (colindixon, 17:01:28)
    14. https://wiki.opendaylight.org/view/TSC:Committer-At-Large_Election_Process says "Normally…the term is 1 year…During the Boron Release, the elected Committers-At-Large (CALs) will only serve on the TSC until the end of the Boron development cycle." (colindixon, 17:01:30)
    15. https://lists.opendaylight.org/pipermail/tsc/2016-November/006328.html the TSC election results were posted 11/22/2016, so technically we should do the new election then, not after Nitrogen (colindixon, 17:01:31)
    16. Vratko Polak proxying for Robert Varga (vrpolak, 17:01:32)
    17. Oxygen DFF registration page https://www.regonline.com/ODLDesignForumOctober2017 (colindixon, 17:01:33)
    18. Oxygen DDF registration page linked to from here https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum#October_9-10th_in_Santa_Clara.2C_CA. (colindixon, 17:01:34)
    19. Oxygen DDF registration page also linked to from here https://wiki.opendaylight.org/view/Events:Main#ODL_Oxygen_Developer_Design_Forum (colindixon, 17:01:34)
    20. shague (shague, 17:02:06)
    21. ACTION: colindixon to provide results of vote to remove non-responsive security response team member (colindixon, 17:02:49)
    22. ACTION: colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2 (colindixon, 17:02:50)
    23. ACTION: CaseyODL to send mail about elections and/or make sure it's on next week's TSC agenda (colindixon, 17:02:51)
    24. ACTION: CaseyODL to add Registration link for DDF to the webpage here: https://www.opendaylight.org/events (colindixon, 17:02:52)
    25. skitt (skitt, 17:03:06)
    26. LuisGomez stands also for vishnoianil (LuisGomez, 17:03:16)
    27. jamoluhrsen (jamoluhrsen, 17:03:30)
    28. abhijitkumbhare (abhijitkumbhare, 17:03:38)
    29. ACTION: phrobb and/or CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up (colindixon, 17:04:23)
    30. ACTION: phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL (colindixon, 17:04:55)
    31. lori (lori, 17:05:04)
    32. there is not a hotel discount for for the Oxygen DDF (colindixon, 17:05:20)
    33. ACTION: projects please, please, please review the CLM violations for your M5 (it seems like DLUX might be the source of most of them) (colindixon, 17:06:10)
    34. klou asks to add the oxygen release plan as well (colindixon, 17:07:05)

  2. events (colindixon, 17:07:46)
    1. https://www.opendaylight.org/events (colindixon, 17:08:05)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:08:12)
    3. https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum on October 9-10th in Santa Clara (colindixon, 17:08:40)
    4. thre will be an OPNFV plugfest in portland in december (colindixon, 17:09:12)
    5. ACTION: CaseyODL to add the December OPNFV plugfest to the agenda (colindixon, 17:09:24)

  3. Carbon (colindixon, 17:09:41)
    1. no updates this week, we are postponing Carbon-SR2 to after Nitrogen (colindixon, 17:09:58)

  4. Oxygen release plan (colindixon, 17:10:22)
    1. ACTION: colindixon to look up the 6-month release cadence docs and draw up a draft Oxygen release plan and send it out to the TSC mailing list (colindixon, 17:11:07)
    2. http://docs.opendaylight.org/en/latest/release-process/release-schedule.html A release schedule but for Nitrogen (zxiiro, 17:11:18)
    3. http://docs.opendaylight.org/en/latest/release-process/release-schedule.html#future-odd-releases (colindixon, 17:11:46)
    4. ACTION: klou to start asking for M0 particpation from projects in Oxygen (colindixon, 17:13:01)

  5. Nitrogen (colindixon, 17:13:32)
    1. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=592032762 - nitrogen tracking sheet (klou, 17:13:48)
    2. By my count we have 11 currently tracked blocking bugs: (colindixon, 17:15:15)
    3. * 1 of which has a merged patch and should probably be verified and closed. (colindixon, 17:15:16)
    4. * 2-4 of which are waiting for review (I'm not sure 9034 and 8988) (colindixon, 17:15:17)
    5. * 3 of which are in progress (colindixon, 17:15:18)
    6. * 3 of which have no patches (colindixon, 17:15:19)
    7. ACTION: jamoluhrsen to look into 9063 9064, it's possible that the fix for 9034 helped (colindixon, 17:15:46)
    8. 8741 startup archetype upgrade to karaf 4, skitt says vorburger is going to get to in in a day or two, it needs to be moved from master to nitrogen (colindixon, 17:16:58)
    9. 9044 After hard reset, Robot fails to establish SSH connection to karaf, looks like vrpolak is looking into it, but he says not this second, currently it's after kill -9, it might work better if we did something more graceful like bin/karaf/stop (colindixon, 17:19:04)
    10. 9057 IncompatibleClassChangeError in RPC test, vrpolak has a workaround which is ugly, looking for cleaner one, should be fixed soon (colindixon, 17:19:23)
    11. https://git.opendaylight.org/gerrit/#/q/message:9034 (colindixon, 17:20:15)
    12. 9034 is a collection of bugs to try to fix OOM issues, with the biggest manifestation of that being 9038 (colindixon, 17:23:38)
    13. the fixes for 9038 and 9034 so far, have helped iwth OOM issues, but haven't resolved the underlying problem with 9038 (colindixon, 17:23:59)
    14. 9038 IllegalStateException: Attempted to close chain with outstanding transaction PingPongTransaction at org.opendaylight.openflowplugin.impl.device.TransactionChainManager.createTxChain (colindixon, 17:24:36)
    15. as above jamoluhrsen will look into 9063/9064 (colindixon, 17:25:22)
    16. 9006 Sporadic cluster failure when member is restarted in OF cluster test, not being worked as far as we know (colindixon, 17:25:49)
    17. 8988 NPE when adding routes to app-peer, Jakub Morvay is working on it locally (colindixon, 17:27:45)
    18. 9092 Exception in ListenerAdapter: java.lang.UnsupportedOperationException: Cannot create XMLStreamReader or XMLEventReader from a org.codehaus.stax2.io.Stax2ByteArr, quick fix is waiting for review, longer fix is a work in progress by skitt, ready by tomorrow (colindixon, 17:28:41)
    19. 9093 With logical SFF and OF based tunnels, chain does not work with SFs on different nodes, waiting for review (colindixon, 17:29:25)
    20. ACTION: colindixon to ping brady on twitter about 9093 (colindixon, 17:30:01)
    21. based on the above, assuming jamoluhrsen has luck 9063/9064, we have two bugs that aren't really being worked: 9044 and 9006 (colindixon, 17:30:50)
    22. ACTION: klou anipbu colindixon and zxiiro to try to find owners for 9063 9064 9044 9006 (colindixon, 17:31:29)
    23. it sounds like we might have a bunch of these fixed on Monday (colindixon, 17:33:03)
    24. ACTION: colindixon to set up a nitrogen sync on Monday (and maybe Wednesday and Friday) (colindixon, 17:33:35)
    25. ACTION: klou to set up release review meetings, ask anipbu for advice on how to set them up (colindixon, 17:35:02)

  6. tutorials (colindixon, 17:40:32)
    1. CaseyODL points out that our tutorials are wildly out of date and we need to update them (or mark them as broken) (colindixon, 17:40:37)
    2. LuisGomez asks what we actually want, CaseyODL says that ideally it woudl be simple instructions with a video showing it that we could post to our youtube channel (colindixon, 17:40:41)
    3. LuisGomez asks if we have any events where we're giving tutorials that we could leverage now? (colindixon, 17:40:47)
    4. CaseyODL says not realy (colindixon, 17:40:52)
    5. colindixon points out that this is pretty easy to do with QuickTime on a Mac if you have one, it's not perfect, but pretty easy (colindixon, 17:42:39)
    6. LuisGomez says information about what's needed (what topics) and insturctions on how to do it (woudl help) (colindixon, 17:44:19)

  7. oxygen DDF (colindixon, 17:44:23)
    1. we still need topcis (colindixon, 17:44:29)
    2. https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum add topics here (colindixon, 17:44:56)
    3. https://www.regonline.com/ODLDesignForumOctober2017 also register, it's free, but there's a $50 no show fee if you register and don't go (colindixon, 17:45:29)

  8. back to tutorials (colindixon, 17:45:34)
    1. abhijitkumbhare asks what tutorials we have and where are they (colindixon, 17:46:12)
    2. CaseyODL says mostly in the youtube channel here: https://www.youtube.com/user/opendaylightproject (colindixon, 17:46:32)
    3. https://www.youtube.com/user/opendaylightproject/search?query=tutorial that's a search for tutorial there (colindixon, 17:47:01)
    4. ACTION: colindixon to post instructions for record videos for tutorials (colindixon, 17:49:19)
    5. screen recording with quicktime instructions - http://etc.usf.edu/techease/4all/getting-started/creating-screen-recordings-with-quicktime-player/ (from vina_ermagan) (colindixon, 17:50:47)

  9. elections (colindixon, 17:50:51)
    1. https://wiki.opendaylight.org/view/TSC:Committer-At-Large_Election_Process says "Normally…the term is 1 year…During the Boron Release, the elected Committers-At-Large (CALs) will only serve on the TSC until the end of the Boron development cycle." (colindixon, 17:50:55)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-November/006328.html the TSC election results were posted 11/22/2016, so technically we should do the new election then, not after Nitrogen (colindixon, 17:50:56)
    3. CaseyODL points out that we normally do TSC elections for a term, but given that elections and release are both calendar-aligned, it might make sense to shift them earlier (colindixon, 17:51:32)
    4. video tutorial for quicktime desktop screen recording: https://www.youtube.com/watch?v=m4s7YF7OEBY (vina_ermagan, 17:52:07)
    5. abhijitkumbhare asks if being release-aligned matters that much, colindixon and CaseyODL note that engagement in OpenDaylight tends to fall along release lines, and many of the things that the TSC does are release oriented (colindixon, 17:54:58)
    6. ACTION: colindixon to send mail about TSC election timing this time (colindixon, 17:59:18)
    7. abhijitkumbhare points out it seems like it's mid october vs. end of november, so not a big deal either way in his mind (colindixon, 17:59:57)

  10. cookies (colindixon, 18:00:01)


Meeting ended at 18:00:04 UTC (full logs).

Action items

  1. colindixon to provide results of vote to remove non-responsive security response team member
  2. colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
  3. CaseyODL to send mail about elections and/or make sure it's on next week's TSC agenda
  4. CaseyODL to add Registration link for DDF to the webpage here: https://www.opendaylight.org/events
  5. phrobb and/or CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up
  6. phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL
  7. projects please, please, please review the CLM violations for your M5 (it seems like DLUX might be the source of most of them)
  8. CaseyODL to add the December OPNFV plugfest to the agenda
  9. colindixon to look up the 6-month release cadence docs and draw up a draft Oxygen release plan and send it out to the TSC mailing list
  10. klou to start asking for M0 particpation from projects in Oxygen
  11. jamoluhrsen to look into 9063 9064, it's possible that the fix for 9034 helped
  12. colindixon to ping brady on twitter about 9093
  13. klou anipbu colindixon and zxiiro to try to find owners for 9063 9064 9044 9006
  14. colindixon to set up a nitrogen sync on Monday (and maybe Wednesday and Friday)
  15. klou to set up release review meetings, ask anipbu for advice on how to set them up
  16. colindixon to post instructions for record videos for tutorials
  17. colindixon to send mail about TSC election timing this time


Action items, by person

  1. anipbu
    1. klou anipbu colindixon and zxiiro to try to find owners for 9063 9064 9044 9006
    2. klou to set up release review meetings, ask anipbu for advice on how to set them up
  2. CaseyODL
    1. CaseyODL to send mail about elections and/or make sure it's on next week's TSC agenda
    2. CaseyODL to add Registration link for DDF to the webpage here: https://www.opendaylight.org/events
    3. phrobb and/or CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up
    4. phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL
    5. CaseyODL to add the December OPNFV plugfest to the agenda
  3. colindixon
    1. colindixon to provide results of vote to remove non-responsive security response team member
    2. colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
    3. colindixon to look up the 6-month release cadence docs and draw up a draft Oxygen release plan and send it out to the TSC mailing list
    4. colindixon to ping brady on twitter about 9093
    5. klou anipbu colindixon and zxiiro to try to find owners for 9063 9064 9044 9006
    6. colindixon to set up a nitrogen sync on Monday (and maybe Wednesday and Friday)
    7. colindixon to post instructions for record videos for tutorials
    8. colindixon to send mail about TSC election timing this time
  4. jamoluhrsen
    1. jamoluhrsen to look into 9063 9064, it's possible that the fix for 9034 helped
  5. klou
    1. klou to start asking for M0 particpation from projects in Oxygen
    2. klou anipbu colindixon and zxiiro to try to find owners for 9063 9064 9044 9006
    3. klou to set up release review meetings, ask anipbu for advice on how to set them up
  6. skitt
    1. colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
  7. zxiiro
    1. klou anipbu colindixon and zxiiro to try to find owners for 9063 9064 9044 9006


People present (lines said)

  1. colindixon (115)
  2. odl_meetbot (15)
  3. jamoluhrsen (4)
  4. zxiiro (4)
  5. vina_ermagan (3)
  6. LuisGomez (2)
  7. kkershaw (1)
  8. shague (1)
  9. klou (1)
  10. vrpolak (1)
  11. anipbu (1)
  12. edwarnicke (1)
  13. lori (1)
  14. CaseyODL (1)
  15. skitt (1)
  16. abhijitkumbhare (1)


Generated by MeetBot 0.1.4.