#opendaylight-meeting: TSC

Meeting started by skitt at 17:01:26 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (skitt, 17:01:32)
    1. skitt (skitt, 17:01:41)
    2. rovarga (rovarga, 17:01:43)
    3. last week's minutes: https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-09-14-17.02.html (skitt, 17:01:53)
    4. edwarnicke (edwarnicke, 17:01:57)
    5. LuisGomez (LuisGomez, 17:01:57)
    6. jamoluhrsen (jamoluhrsen, 17:02:12)
    7. jamoluhrsen for Sam Hague (jamoluhrsen, 17:02:19)
    8. ACTION: colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2 (skitt, 17:02:37)
    9. anipbu (anipbu, 17:02:39)
    10. ACTION: CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up at the OPNFV summit in portland, specifically figure out how many ODLers plan to go (skitt, 17:02:51)
    11. Anil Vishnoi (vishnoianil, 17:03:13)
    12. ACTION: phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL (skitt, 17:03:23)
    13. Vina Ermagan proxy for Lori Jakab (vina_ermagan, 17:03:30)
    14. ACTION: CaseyODL to advertise the OPNFV plug-fest in Portland (skitt, 17:04:06)
    15. CaseyODL will be inviting OPNFV participants to come to the ODL DDF (skitt, 17:04:19)
    16. reminder to *please* register for the DDF and submit topics (skitt, 17:04:47)
    17. abhijitkumbhare (abhijitkumbhare, 17:05:31)
    18. ACTION: klou to ping projects for M0 again (skitt, 17:05:47)
    19. Oxygen release plan: https://wiki.opendaylight.org/view/Simultaneous_Release:Oxygen_Release_Plan (skitt, 17:07:07)
    20. CaseyODL and phrobb report that the board is interested in the security manager role (skitt, 17:08:22)
    21. phrobb mentions that the board would appreciate the TSC's participation in defining the role and job description (skitt, 17:08:39)
    22. ACTION: CaseyODL and phrobb to write a draft of the security manager job description for discussion and approval (skitt, 17:10:18)
    23. TrieMap: https://lists.opendaylight.org/pipermail/tsc/2017-September/007932.html (skitt, 17:11:30)
    24. dependencies: https://lists.opendaylight.org/pipermail/tsc/2017-September/007937.html (skitt, 17:11:39)
    25. rovarga points out that the existence of infrautils, in incubation, appears to block the creation of another project with a different scope (skitt, 17:12:38)
    26. no point in moving the code from yangtools to infrautils since yangtools is mature (skitt, 17:13:16)
    27. TTP is an example of a small project which is a "happy-camper", not moving at all (skitt, 17:14:59)
    28. the read-out boils down to copy-pasting (skitt, 17:15:10)
    29. that's with TTP participating in autorelease (skitt, 17:15:16)
    30. projects not participating in autorelease could be even simpler (skitt, 17:15:34)
    31. vishnoianil points out that creating a project does have a cost (skitt, 17:16:55)
    32. edwarnicke says that merging unrelated projects together ends up hiding things (skitt, 17:17:29)
    33. it creates the illusion that there's just one thing to release manage (skitt, 17:17:40)
    34. the costs to create a project are minimal, the costs to run it depend on the activity in the project (skitt, 17:18:14)
    35. mostly moving deckchairs around (skitt, 17:18:31)
    36. abhijitkumbhare suggests making it a sub-project under infrautils (skitt, 17:19:54)
    37. rovarga reminds us that infrautils is still in incubation and probably couldn't pass graduation review currently (skitt, 17:20:40)
    38. infrautil's scope includes two items only (skitt, 17:20:58)
    39. its release plan is empty as are its release notes (skitt, 17:21:20)
    40. yangtools can't depend on infrautils (skitt, 17:21:52)
    41. abhijitkumbhare points out that infrautils' name suggests it's a utility host project (skitt, 17:24:17)
    42. rovarga asks whether the lldp move was executed (skitt, 17:24:50)

  2. events (skitt, 17:25:38)
    1. lldp move has not been executed upon (rovarga, 17:25:47)

  3. Carbon (skitt, 17:26:11)
    1. klou asks when we plan to release SR2 (skitt, 17:26:38)
    2. rovarga says we discussed releasing it two weeks or so after Nitrogen (skitt, 17:27:01)
    3. jamoluhrsen asks if we can start the process ASAP (skitt, 17:27:14)
    4. we need autorelease to run, see where we are with CSIT etc. (skitt, 17:27:26)
    5. anipbu asks if we're still calendar-based for Nitrogen (skitt, 17:28:06)
    6. rovarga has a bunch of patches for SR1 (skitt, 17:28:21)
    7. if we don't shift the dates, do we have enough time to get feedback on Nitrogen to do anything useful in SR1 (skitt, 17:28:37)

  4. Nitrogen (skitt, 17:29:24)
    1. RC4 this week (skitt, 17:29:34)
    2. projects have been signing off: out of 41, only 8 have signed off (skitt, 17:29:47)
    3. 9 release note patches need to be updated and merged (skitt, 17:30:06)
    4. CSIT: out of 55, 9 issues haven't been checked off (skitt, 17:30:19)
    5. how much time do we give projects to sign off? (skitt, 17:31:04)
    6. vishnoianil suggests a 24h notice and TSC vote on the mailing list (skitt, 17:31:27)
    7. it should be 48h, so by Monday (skitt, 17:31:59)
    8. provisionally approve? (skitt, 17:32:48)
    9. VOTE: Voted on "how shall we vote to approve the release, assuming all the projects sign off and no further blocking bugs?" Results are (skitt, 17:35:26)
    10. VOTE: Voted on "how shall we vote to approve the release, assuming all the projects sign off and no further blocking bugs (on the Nitrogen branch)?" Results are, TWS: 2, pre-approve: 5 (skitt, 17:38:12)
    11. shague and jamoluhrsen voted email (skitt, 17:38:24)
    12. AGREED: we'll have a pre-approve vote (skitt, 17:38:40)
    13. VOTE: Voted on "Does the TSC approve RC4 as the Nitrogen release, as long as all projects sign off by Monday 25th TWS time and all blocker bugs are verified in Nitrogen, and we don't respin?" Results are, +1: 8 (skitt, 17:43:27)
    14. shague voted +1 (skitt, 17:43:35)
    15. AGREED: If by Monday TWS, if all projects have signed off (blockers and release), and all blocker bugs are fixed verified in Nitrogen, and we don't respin, the TSC approves RC4 as the Nitrogen release (skitt, 17:44:43)
    16. anything else means a re-vote either during the TWS or by email (skitt, 17:44:58)
    17. ACTION: klou to chase up the missing sign-offs (skitt, 17:45:08)
    18. ACTION: klou to provide the TSC with daily updates (skitt, 17:45:22)
    19. ACTION: klou to ask vtn/coordinator and opflex to approve their artifacts (skitt, 17:45:48)
    20. we'll discuss Nitrogen SR1 and Carbon SR2 dates over email next week (skitt, 17:47:26)
    21. reminder that next week's TSC meeting is APAC-friendly (skitt, 17:47:43)

  5. Oxygen (skitt, 17:47:57)
    1. Oxygen release plan: https://wiki.opendaylight.org/view/Simultaneous_Release:Oxygen_Release_Plan (skitt, 17:48:23)
    2. no M5 for Oxygen (skitt, 17:49:53)
    3. M1/M2/M3 need to be split out, the merge was only for Nitrogen (skitt, 17:50:21)
    4. http://docs.opendaylight.org/en/latest/release-process/release-schedule.html (anipbu, 17:52:00)
    5. calendar-based release schedule: http://docs.opendaylight.org/en/latest/release-process/release-schedule.html (skitt, 17:52:30)
    6. ACTION: klou to update the release plan (skitt, 17:52:50)
    7. rovarga suggests scheduling a session on lessons learnt from Nitrogen (skitt, 17:55:42)
    8. at a TWS (skitt, 17:55:46)
    9. ACTION: rovarga to add a session to TWS page (skitt, 17:55:58)

  6. system integration and testing (skitt, 17:56:24)
    1. rovarga asks about the reduction in test jobs (skitt, 17:56:56)
    2. rovarga wonders whether it was widely discussed and asks why system tests are behaving in this way (the "all" jobs) (skitt, 17:57:47)
    3. jamoluhrsen says it was discussed, he understands the pain (skitt, 17:57:57)
    4. jamoluhrsen says vrpolak has ideas on how to improve the jobs (loading features, then starting the tests) (skitt, 17:58:19)
    5. rovarga says we need to know the state of the controller if we're testing individual features in system tests (skitt, 17:58:53)
    6. and what are we doing about infra not handling our release load (skitt, 17:59:04)
    7. jamoluhrsen says we can add "only" jobs back piecemeal starting now (skitt, 17:59:16)
    8. should we escalade our infra issues to the board? (skitt, 17:59:40)
    9. jamoluhrsen asks if there's value in having the "all" jobs (skitt, 18:00:02)
    10. rovarga says they have value in certain cases (skitt, 18:00:12)
    11. from a system perspective, validating e.g. HA is better done in "only" jobs than "all" jobs (skitt, 18:00:39)
    12. LuisGomez says a good practice that some jobs needs to be "only": HA, performance, longevity etc. (skitt, 18:01:17)
    13. projects can choose which tests they want (skitt, 18:01:31)
    14. vrpolak was thinking of running "only" jobs daily and "all" jobs weekly, hard to implement so dropped for now, perhaps time to revisit (skitt, 18:01:54)
    15. LuisGomez says the "all" doesn't need to run all the time, it can be run on demand in specific circumstances (skitt, 18:02:12)
    16. vrpolak says it's important for the distribution, so we know we're integrating features which do work together (skitt, 18:02:33)
    17. LuisGomez says cluster, performance etc. jobs only make sense for some projects, they should be opt-in (skitt, 18:03:53)
    18. rovarga suggests running the "all" jobs for info once a week, until we get to M4 at which point they become important (skitt, 18:04:32)
    19. in any case the jobs need to be fixed so the instance at least starts up, otherwise impossible to debug (skitt, 18:04:52)
    20. ACTION: vrpolak to open a bug on releng/builder to track this (skitt, 18:05:50)
    21. vrpolak asks how we update integration/test requirements (skitt, 18:06:03)
    22. we'll discuss it on the mailing list (skitt, 18:06:36)
    23. rovarga says it's late in the game (skitt, 18:06:42)

  7. cookies (skitt, 18:06:46)


Meeting ended at 18:06:58 UTC (full logs).

Action items

  1. colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
  2. CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up at the OPNFV summit in portland, specifically figure out how many ODLers plan to go
  3. phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL
  4. CaseyODL to advertise the OPNFV plug-fest in Portland
  5. klou to ping projects for M0 again
  6. CaseyODL and phrobb to write a draft of the security manager job description for discussion and approval
  7. klou to chase up the missing sign-offs
  8. klou to provide the TSC with daily updates
  9. klou to ask vtn/coordinator and opflex to approve their artifacts
  10. klou to update the release plan
  11. rovarga to add a session to TWS page
  12. vrpolak to open a bug on releng/builder to track this


Action items, by person

  1. CaseyODL
    1. CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up at the OPNFV summit in portland, specifically figure out how many ODLers plan to go
    2. phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL
    3. CaseyODL to advertise the OPNFV plug-fest in Portland
    4. CaseyODL and phrobb to write a draft of the security manager job description for discussion and approval
  2. rovarga
    1. colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
    2. rovarga to add a session to TWS page
  3. skitt
    1. colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
  4. vrpolak
    1. vrpolak to open a bug on releng/builder to track this
  5. UNASSIGNED
    1. klou to ping projects for M0 again
    2. klou to chase up the missing sign-offs
    3. klou to provide the TSC with daily updates
    4. klou to ask vtn/coordinator and opflex to approve their artifacts
    5. klou to update the release plan


People present (lines said)

  1. skitt (114)
  2. odl_meetbot (20)
  3. vrpolak (8)
  4. rovarga (8)
  5. LuisGomez (7)
  6. edwarnicke (5)
  7. abhijitkumbhare (5)
  8. jamoluhrsen (4)
  9. anipbu (4)
  10. vishnoianil (4)
  11. vina_ermagan (3)
  12. CaseyODL (1)


Generated by MeetBot 0.1.4.